Think I messed something up blue spring upgrade - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-15-2013, 06:13 PM
Serving Our Country!
 

Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,858
Thanks: 79
Thanked 93 Times in 58 Posts
Feedback Score: 0 reviews
Think I messed something up blue spring upgrade

So Saturday (last) I replaced my inner tie rod ends pass/drivers side. and installed the blue upgrade fuel pressure regulator spring. I had a couple of o-rings left over and only 2 i know I didnt need I have about a 1/2in black one left. heres my issue...

started it this morning and now where my fuel filter (along drivers side frame rail) the primeing noise when I first turn the key to on for around 5 seconds makes a much louder almost vaccum sound. never did that til I changed the fuel spring. im a little worried. my ficm voltage is 47.5 and was replaced in 2011, i changed the fuel/oil filters with oem for my truck. I have an 04 f350 lariat 4x4, 50440ish miles and new oil cooler, bpd egr, 6in lift 35's and my ect is average 184, my eot average 187 so around 3 difference. she runs good but the loud sound started after fuel spring change.

thanks for input im fairly new to the infamous 6.0L....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-15-2013, 06:18 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Did you get the oring on the black plastic poppet? A few orings go on the fuel lines, no reason not to change those. On a side note, your thermostat is stuck open, replace with OEM only.
Reply With Quote Quick reply to this message
  #3  
Old 01-15-2013, 06:30 PM
Serving Our Country!
 

Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,858
Thanks: 79
Thanked 93 Times in 58 Posts
Feedback Score: 0 reviews
black poppet? are you talking about the little black cup the new blue spring sits inside of? I didn't see how an o ring fits. does it go in-front of black cup or behind it seated in the fuel filter housing?

My truck has been running 180 maybe 190s on a 4 hr trip for about 3 months now. did I do any damage? ive been paranoid to do an elc swap and flush. the last time i literally destroyed my 06 king ranch... and I cant afford another 6k etc...
Reply With Quote Quick reply to this message
  #4  
Old 01-15-2013, 07:01 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Iirc, it goes in the back. If you are running less than 45psi, you are likely causing damage. Only a fuel pressure check will verify that.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #5  
Old 01-22-2013, 10:54 AM
Premium Member
 

Join Date: Sep 2012
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Jloffermann View Post
ive been paranoid to do an elc swap and flush. the last time i literally destroyed my 06 king ranch... and I cant afford another 6k etc...
Just curious as to how you destroyed your previous truck by doing an ELC swap and flush--what went wrong and why?
Reply With Quote Quick reply to this message
  #6  
Old 01-22-2013, 10:10 PM
Serving Our Country!
 

Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,858
Thanks: 79
Thanked 93 Times in 58 Posts
Feedback Score: 0 reviews
I was very new to the 6.0s when i drained the coolant it looked like rusty water so i ran a flush agent with destilled water. And got a limp mode code about week later that went away. About weekn half came back. So the oil cooler caused my egr to fail caused headgasket. Caused head issue. Then after 1 week in shop hpop pump went out and leaked. And fuel injector took out engine so I know not all problems related to clogged oil cooler ( the techs showed it to me) but it was bad so now i have my current 04 new oil cooler in 2011, bpd egr in oct 2012 first coolant filter changed after 500 miles was clean and less then 4k on cufrent ford gold my average ECT 180, and 183-184 EOT so 4 degree temp difference i dont want to mess eith anything csnt afford it...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors