Cooling problem, power problem... - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-08-2013, 06:38 PM Thread Starter Rookie
Join Date: Sep 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cooling problem, power problem...

I have an 04 that has 102k miles on it. In the last 3 months it has developed a cooling system problem that has baffled me. the cooling system is building pressure so high that it pushes out of the degas bottle as steam. Its minute under normal load, but under high load/high boost there is a huge amount of coolant pushing out. Ideas?

Also I have noticed that the truck seems to be low on power, especially when towing. I tow a trailer to the dunes, 5k pounds, and the truck maxxes at 50 mph pulling a hill, 2% incline to 6% incline. i believe that i should be able to run up the hills no problem with only 5k on the trailer. Ideas?

The truck runs smooth, no codes, and without any signs of not running well. I am open to ideas that these issues could be related or totally separate.

Thanks for any input you can provide!
TruStang is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome