Edge Insight CTS - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-05-2013, 12:53 PM Thread Starter
Member
 
lrstrck's Avatar
 
Join Date: Feb 2010
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge Insight CTS

Posted awhile back that I was getting the Insight. Well, it finaly arrived. Now for those of you that have this device, what are the "main" PIDs that I need to keep an eye on. I know the FICM is one, and Battery what are the others?

I have also noticed that during start up my battery voltage drops down to around 11.0v and with in 60 sec. it gets to 13-14v and never drops again. Is this due to glow plugs and alternator kicking on?

Thanks in advance.....and Roll Tide!!!!


2005 cc 6.0l.....
lrstrck is offline  
post #2 of 5 Old 01-05-2013, 12:54 PM
Mod Newbie

 
dhanna6powerstroke's Avatar
 
Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 13,144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 6
Thanked 141 Times in 133 Posts
Feedback Score: 2 reviews
ECT and EOT are a must. Fuel pressure is another real big one and EGT but you have to buy the probe and sender separate to monitor those.

dhanna6powerstroke is offline  
post #3 of 5 Old 01-06-2013, 10:21 AM
Compression Ignition Addict
 
Join Date: Apr 2012
Posts: 1,504
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Thanks: 19
Thanked 32 Times in 32 Posts
Feedback Score: 0 reviews
your batt voltage is gonna drop. the starter uses a lot of power, as well as the glow plugs. i wouldn't worry about it

the richest ones are not those who have the most, but those who need the least
kaya is offline  
post #4 of 5 Old 01-06-2013, 01:36 PM
Powerstroke.org Rookie
 
Nick 6.0's Avatar
 
Join Date: Dec 2012
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I plugged in my Insight two days ago and saw the same thing with the voltage but I was suspecting it. I had a slew of bad Autozone alternators that sent me to the local shop and the electrical guru explained it to me and it has something to do with the Ohms that the glow plugs draw.... Its normal thats the bottom line. I have the EGT probe on its way and I currenty watch EOT, ECT, FiCM Volts, Boost (cause I like to watch the gauges move) and Voltage (which im going to replace with EGT when it arrives)
Nick 6.0 is offline  
post #5 of 5 Old 01-07-2013, 05:10 AM
Premium Member
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
I watch voltage, ect, eot, boost, icp, ebp, vgt%, and ficm. I would get a fuel pressure guage and sender off of ebay for fuel pressure.

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome