Truck Shuts off and Refires while driving. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-20-2012, 01:51 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck Shuts off and Refires while driving.

I have a 2005 Excursion. About a year ago I did head studs, egr delete, head gasket and a few of the other recommended corrections. With an Excursion the motor has to come out as the cab cannot be lifted off. About two months after getting the truck back on the road I was driving on the interstate on the cruise control and the truck started slowing down. Looked down and the glow plug light was lit and then went off. I pressed the accelerator and the truck was fine.

I have been pulling my hair out trying to figure out why this truck will shut off and refire at random times. If I am traveling in excess of 10MPH or so it refires itself, otherwise I have to throw it in neutral and hit the key.

The problem seems to be getting worse. I took it to a Ford dealer for diagnosis and they want $$$$ to replace the EGR(deleted) and Mass airflow before they will diagnose the other problem. I call that extortion.

Sometimes the theft light will start to flash rapidly while driving. When this happens the truck is about to cut off and restart in rapid succession about 4 times. Then the theft light will flash for a minute and then flash the 16 code.

I have replaced cam and crank shaft position sensors to no avail. I just know this is a short somewhere because the problem is intermittent, but how the heck to you go about finding that?

Any and all help appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-20-2012, 02:56 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Plainview, MN
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if the theft light is flashing i would assume its a computer problem or wires chaffed. kinda seems like something is grounding out then breaking the connection. IDK is the theft system is passive on the superduty or if it has an ignition kill maybe something to look in to
Reply With Quote Quick reply to this message
  #3  
Old 02-12-2013, 11:55 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have an update to this situation.

I have taken the truck to another Ford dealer and they have kept the truck for a month. First they tell me that they cannot run all of the tests on my truck because the vin number says it is an 05 but some of the configuration is 04. This truck has the egr throttle plate in it which is not supposed to be in 05 trucks.

At any rate they tell me there is a fault in the circuit that is responsible for the EGR sensor, Mass Airflow sensor and the ICP sensor. The service guy calls to tell me that if they unplug the ICP the truck will run without shutting off. Of course this cannot be left unplugged because it negatively effects performance and mileage. He says for $791 he will replace and problem solved.

The truck still shuts off. Then he tells me the only other item that can be responsible is the accelerator pedal. He will sell me one for $800 plus labor. I call Tousley and get one for half that and take it to them. Today he calls and says the truck still shuts off. They are going to replace the ICP again just in case they got a bad one.

So now I imagine my bill with them to be close to $2k and truck still broken. He says basically at this point replace entire wiring harness or possibly bad PCM.

I am at my wits end with this truck. I love the truck and I'm sure I can't sell it as is. Nobody is going to buy a truck that shuts off from time to time.

If anyone can help with advice on this issue I would be forever grateful.

Regards,

Ken
Reply With Quote Quick reply to this message
  #4  
Old 02-22-2013, 11:45 AM
opm opm is offline
Powerstroke.org Rookie
 

Join Date: Jan 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I know this might sound ridiculous but how heavy is your key chain?? I have had some issues with my large key chain swinging and just timed right hit a bump and it will momentarily turn the truck off then on again I had to change out the key ignition for a new one.... problem fixed
Reply With Quote Quick reply to this message
  #5  
Old 02-22-2013, 01:46 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would love it if that was the issue

It exhibits this behavior even with just the key and no keychain.

As an update the dealer says now they think there is no short in the harness. He says the tech was able to figure out a way to individually load test all of the wires in the harness and can't find a short. They are now thinking it might be the PCM. I guess it's worth a try but this is getting awfully expensive.

Replacing the accelerator pedal did not correct the problem.
Reply With Quote Quick reply to this message
  #6  
Old 02-22-2013, 07:16 PM
Powerstroke Techie


 

Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,022
Thanks: 80
Thanked 60 Times in 32 Posts
Feedback Score: 13 reviews
Quote:
Originally Posted by stainman View Post
I have a 2005 Excursion. About a year ago I did head studs, egr delete, head gasket and a few of the other recommended corrections. With an Excursion the motor has to come out as the cab cannot be lifted off. About two months after getting the truck back on the road I was driving on the interstate on the cruise control and the truck started slowing down. Looked down and the glow plug light was lit and then went off. I pressed the accelerator and the truck was fine.

I have been pulling my hair out trying to figure out why this truck will shut off and refire at random times. If I am traveling in excess of 10MPH or so it refires itself, otherwise I have to throw it in neutral and hit the key.

The problem seems to be getting worse. I took it to a Ford dealer for diagnosis and they want $$$$ to replace the EGR(deleted) and Mass airflow before they will diagnose the other problem. I call that extortion.

Sometimes the theft light will start to flash rapidly while driving. When this happens the truck is about to cut off and restart in rapid succession about 4 times. Then the theft light will flash for a minute and then flash the 16 code.

I have replaced cam and crank shaft position sensors to no avail. I just know this is a short somewhere because the problem is intermittent, but how the heck to you go about finding that?

Any and all help appreciated.
I had 2 excursions do this exact same thing and they both had the same problem!!!! On the driver side there is a round plug underneath everything on the fender!! It would appear to be connected but it isn't snapped in all the way! When the motor is torqued it pulls apart and shut truck of for a second then runs again!! Here is what to do start the truck and go to the driver fender and start pulling the harnesses one at a time towards the engine it should shut truck off when you pull the right one!!! Hope this helps!!
Reply With Quote Quick reply to this message
  #7  
Old 04-13-2014, 03:51 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
U ever figure out the problem with this mine is acting up the same way thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors