Turbo Lag - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 12-17-2012, 02:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation Turbo Lag

when i first step on the gas the truck seems to run on only the motor power and literally has no power. the turbo doesnt spool up untill after 30 seconds or more. i know the injectors are going but i have had this problem since i got the truck and before i replaced the turbo completely. if any one can help it would be much appreciated
Gaither0311 is offline  
post #2 of 8 Old 12-17-2012, 03:14 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
If the injectors are going, it's for a reason. Are you running motorcraft or racor filters, have you checked the filters? Have you checked your fuel pressure, egr valve stuck open, do you have a monitor?

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #3 of 8 Old 12-17-2012, 03:15 PM
Compression Ignition Addict
 
jermcd's Avatar
 
Join Date: Oct 2010
Location: Central, OH
Posts: 322
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
30 seconds???

currently driving a 335i bmw, no more powerstoke

Previous powerstrokes-
2002- F250 XL 7.3 auto, 4x4
2001- F250 Lariat 7.3 auto, 4x4
2002- F350 Lariat 7.3 Dually, auto, 4x4. 141k miles
jermcd is offline  
post #4 of 8 Old 12-17-2012, 03:27 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by jermcd View Post
30 seconds???
Yea, lol, thats not turbo lag.

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #5 of 8 Old 12-17-2012, 03:30 PM
Compression Ignition Addict
 
6.0f250firstcar's Avatar
 
Join Date: Jul 2012
Location: New Joisey
Posts: 3,594
Thanks: 23
Thanked 62 Times in 46 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
So it takes 30 seconds for the boost gauge on the dash to register?


Sent from my iPhone using AutoGuide.com Free App

Ryan
6.0f250firstcar is offline  
post #6 of 8 Old 12-17-2012, 06:47 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Its my dads truck and I can't stand to sit here and watch it get destroyed. I just put a new Turbo in with an egr delete about a year ago he has a bully dog chip on his **** and keeps it performance. When you put it in gear and press the gas it has a hesataion and the Turbo is not spooling up at the right time all filters should have been done 2 months ago
Gaither0311 is offline  
post #7 of 8 Old 12-17-2012, 07:21 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by Gaither0311 View Post
Its my dads truck and I can't stand to sit here and watch it get destroyed. I just put a new Turbo in with an egr delete about a year ago he has a bully dog chip on his **** and keeps it performance. When you put it in gear and press the gas it has a hesataion and the Turbo is not spooling up at the right time all filters should have been done 2 months ago
I know what you mean, my old man has a 7.3 that he thinks runs fine, its got problems. I checked the boost one day, maxes out at 6psi. It runs rough, clackity clack.......etc. I just quit worring about it, he thinks it's fine, thats what matters I suppose. I have the same year 7.3 with 308k, runs better than his, with 240k or so. I hear those bully dogs are hard on transmissions. Your probably fighting a loosing battle.....idk.

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #8 of 8 Old 12-18-2012, 04:32 AM
Powerstroke Techie
 
Join Date: Apr 2012
Posts: 2,413
Thanks: 47
Thanked 100 Times in 100 Posts
Mentioned: 54 Post(s)
Quoted: 129 Post(s)
Feedback Score: 0 reviews
what year is the truck?
tried returning to stock?
check the codes
check for boost leaks
exhaust leaks at the up pipes/manifolds
check your ebp, map and maf readings
check the ebp tube and harness

the richest ones are not those who have the most, but those who need the least
kaya is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome