05 F 250 fuel system problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-12-2012, 05:10 PM
Powerstroke.org Rookie
 

Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
05 F 250 fuel system problem

Pickup was running like it was not getting right fuel amount spuddering and losing power so I changed the fuel filters like I have more then a handful of times causee that's what I expected to be wrong, cycled it 3 times and it cranked right up like always ran for about 2 minutes started choking out and shut off and hasn't started since had a machanic come out to my place and hee said sometimes it just takes some starting fluid to get it started so we tried that and no luck cranks on with the starting fluid then shut off could the fuel pump be out or what sounds wrong had new injectors put in like 20k miles ago at 100k miles so it shouldn't be them any help would be awsome thank you
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-12-2012, 05:38 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,498
Thanks: 5
Thanked 99 Times in 94 Posts
Feedback Score: 2 reviews
Very bad idea to use starting fluid. Get a fuel pressure gauge and check fuel pressure at the filter housing on engine. Fuel pressure needs to be 45-48 minimum. Also, check FICM voltage with key on and while cranking. FICM needs to be 46-48 volts. Any lower and it's junk. What year truck do you have?
Reply With Quote Quick reply to this message
  #3  
Old 12-12-2012, 05:43 PM
Powerstroke.org Rookie
 

Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 ill check tomorrow have an extended warrenty so I might just have it towed to dealer and see what they say jjust didn't know if anyone knew if it might be something simple
Reply With Quote Quick reply to this message
  #4  
Old 12-12-2012, 05:45 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,498
Thanks: 5
Thanked 99 Times in 94 Posts
Feedback Score: 2 reviews
That's the most simple and first things to check. If that checks out, you're gonna have to start checking the HPO system.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors