Accelerator malfunction-newbie here - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-26-2012, 10:55 AM Thread Starter Rookie
Join Date: Nov 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Accelerator malfunction-newbie here

2003 F-250 6.0

While driving at highway speeds, I will lose control of my accelerator. Push on it and nothing will happen. I have to pull over shut engine off and restart, that seems to reset it. Then I am good again but have to be very gentle with the throttle or it will kick out again. This only seems to happen if there is rain or snow and the roads are wet and have been wet for sometime driving in it. The accelerator pedal module inside has been replaced 4 times (per the dealer diagnosis) and I still continue to have this problem. I can continue to drive it using the cruise control to throttle up and down. When I restart the engine after loss of accelerator I get the check engine light on the dash. After the truck sits overnight I will not get the check engine light when started. Any ideas? Similar problems?

lakeerietim is offline  
Sponsored Links
post #2 of 3 Old 11-27-2012, 10:24 PM
Premium Member
turbotibbo's Avatar
Join Date: Mar 2012
Posts: 1,232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 8
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
check for codes when the cel is on?

2006 ford f350 xlt cclb
blue spring mod
6.4 banjo bolts
gogo direct cluth solenoid
Insight cts with pyro
str8 pipe , fuel pressure gauge
air raid cold air
zoodad mod
high idle mod
sinister coolant filter kit ec-1 rated
58 volt ficm
powermax turbo , sinister y pipe
egr delete
sct x3 with running looney wild , spd early lock up
arp studs , updated stc fitting ,stand pipes,
dummy plugs , new oem injectors
turbotibbo is offline  
post #3 of 3 Old 11-28-2012, 06:17 AM
Compression Ignition Addict
Turbostang500's Avatar
Join Date: Oct 2011
Location: Dover
Posts: 1,632
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tim, I would maybe check the accel pedal itself. They have a tps in them or at least the 7.3's do.

Are you on Erie in Ohio?


2000 F250 PSD SCSB 4X4 418k miles straight pipe gauges 2" leveling kit 315/75r16's
6637 with custom intake pipe. TS Performance 6 position chip!

Please don't confuse my attitude with my personality.. my personality is who I am,my attitude depends on who you are...
Turbostang500 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome