Im new on here - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2012, 07:52 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im new on here

I have a 06 f350 and put an edge attitude in in and it runs great but after i put the chip in the alternator took a crap (was told that was common) but after replacing that the truck ran great but every once and a while the battery light would come on the dash but the chip would say 13.9v and then turn off eventually. It would not start this morning and then on the way home from work it dropped to 9 then 8v and the battery light came back on along with the "limp mode" light and abs. What is going on here? I am new to diesels and this is my first one.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-28-2012, 08:30 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 825
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like you either didn't get a good alternator when you replaced it the first time or your batteries are struggling too. Could be both. I had that happen to me once but it was a little longer than your talking if your meaning a few days. But it turned out that the alternator I replaced the bad one with was bad too. get it to an auto parts store and have the batteries and the alternator tested.
Reply With Quote Quick reply to this message
  #3  
Old 10-28-2012, 09:27 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's been about two months I'd say. I live in Colorado and its getting cold now...down in the 20s and 30s at night. But it could be the alternator I suppose. Ill have to jump it tomorrow and take it back to the guys at Firestone. They did an awesome job but maybe just a bad part? Could I fight for new batteries if the alternator they put in was bad and killed the batteries? Think I've got a chance?
Reply With Quote Quick reply to this message
  #4  
Old 10-29-2012, 04:06 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 825
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's definitely worth a shot. I'm not sure... when mine happened they replaced the alternator but my batteries were still good.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors