Smell of coolant passenger side of motor - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-26-2012, 09:53 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2012
Posts: 378
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Feedback Score: 0 reviews
Smell of coolant passenger side of motor

After I shut the truck off I smell a very faint smell of coolant coming from the passenger side of the truck. I can smell it faintly if I stick my head in the front passenger side wheel well. Can't find any coolant on the ground though

2005 Dark Blue F-250 Harley Davidson 4x4. SCT Livewire TS, 4" Silverline TBE, Sinister intake elbow, Riff Raff turbo boots, Blue spring, 6.4 banjo bolts, Sinister coolant filter, Fleetguard OAT, IPR EGR delete, ARP studs.

1998 Dodge Viper GTS. Silver/Blue stripes 1 of 21: Corsa exhaust, high flow cats, K&N filters, smooth tubes
Invasivore is offline  
post #2 of 3 Old 10-26-2012, 10:05 AM
Fill it up again Dummy
 
mhatlen's Avatar
 
Join Date: Sep 2012
Location: Central Valley, Sierra Mountains, California
Posts: 2,300
Thanks: 38
Thanked 112 Times in 101 Posts
Mentioned: 6 Post(s)
Quoted: 187 Post(s)
Feedback Score: 0 reviews
Make sure its not blowing out of cap,check the hoses to heater core as well as the heater control valve ( which is on top of valve cover and has a vacuum hose to it depending on model).
I would get out a 7 mm socket or straight screwdriver and snug up all your hose clamps.


2006 F250 LARIAT CCSB 4X4
ARP Studs, O-Ringed Heads
X4 PHP 65 HP Custom Tow Tune
Atlas40 Ficm Tune
CAT EC-1 Coolant, IPR Coolant filter
Fass-125 to a Adjustable Pressure Reg.
Turbo-back SS 4" pipe, Corsa Muffler -7" Tip
6.4 starter, DC Power 270 amp alt
Die Hard Platinum AGM all 2/0 Cables
7" lift w: Icon Progressive Coil Springs
2008 up Carli/Deaver rear springs
All riding on some Fatty-Daddy 38/15.50/18 Toyo's
mhatlen is offline  
post #3 of 3 Old 10-26-2012, 11:28 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2012
Posts: 378
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Feedback Score: 0 reviews
Found it! lower radiator coolant hose clamp was loose. It was the only place I never checked (of course that is how it always works!).

2005 Dark Blue F-250 Harley Davidson 4x4. SCT Livewire TS, 4" Silverline TBE, Sinister intake elbow, Riff Raff turbo boots, Blue spring, 6.4 banjo bolts, Sinister coolant filter, Fleetguard OAT, IPR EGR delete, ARP studs.

1998 Dodge Viper GTS. Silver/Blue stripes 1 of 21: Corsa exhaust, high flow cats, K&N filters, smooth tubes
Invasivore is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome