surging and sometimes wont start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-20-2012, 06:57 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
surging and sometimes wont start

So this problem hasgotten worse over a month. It is almost like a defrost surge but has been getting really bad to the point sitting at a stop light it will lung u foward. And when it doesn't start it is random. I have done fuel filters cleaned the egr twice checked the ficm it was good replaced the air intake temp sensor. But have no ideas now.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-21-2012, 05:50 PM
Premium Member
 

Join Date: Feb 2008
Location: Cleveland,Tx
Posts: 128
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to kmacicek Send a message via Yahoo to kmacicek
have you scanned it, does it have any codes that are showing up?
Reply With Quote Quick reply to this message
  #3  
Old 10-21-2012, 07:41 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have scanned it and nothing is coming up i even made it throw a code by disconnecting the icp sensor. Today I went thew the wiring harness that the icp.sensor goes into and found nothing I also blew out the connections to the computer and made sure it was good there
Reply With Quote Quick reply to this message
  #4  
Old 10-23-2012, 05:58 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
What year is your truck, how are you monitoring/pulling codes? Have no idea what a defrost surge is, but it sounds like a bad icp sensor.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #5  
Old 10-23-2012, 07:43 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its an 05 and. I have an edge. at an idle it kicks up anywhere from 50 to 100 rpms almost as if u started to let off the brake it takes off. I have played with the icp sensor and looked at the wires but did not see anything nobody can get the sensor for 3 days and its not cheap either and also hate to just throw parts at it.
Reply With Quote Quick reply to this message
  #6  
Old 10-24-2012, 02:35 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Well if you have an edge, watch icp values to see if they are steady, or moving when it surges.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #7  
Old 10-24-2012, 05:34 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will have to see if I can get it to monitor it thank u I will let u know what happens
Reply With Quote Quick reply to this message
  #8  
Old 10-31-2012, 06:27 PM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Location: Mishawaka
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem with an 04. 58K miles. Had the icp replaced back in Aug. Ran great for about two weeks. Then went back to lurching. I removed the icp harness about three weeks ago. Haven't had a problem since. Not as responsive, but it's a work truck. Wondering if leaving it disconnected will do any long term damage??? Is sure runs good though...
Reply With Quote Quick reply to this message
  #9  
Old 10-31-2012, 06:34 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It does not moitor the icp sensor but I had a shop look at it and they found the altinator was not outing out any volts I replaced it and have not had a problem yet knock on wood
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors