Bunch of black smoke shooting out exahuast - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-17-2012, 07:23 AM Thread Starter
Powerstroke.org Rookie
 
Duce Stroker's Avatar
 
Join Date: Oct 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bunch of black smoke shooting out exahuast

My question is, i have a 2003 F250, most of the issues i have already taken care of. But now it has a rough idle blows out black smoke when your on the gas and when you just drive. Its shooting out an EGR code, i have replace the EGR valve, clean the mass flow air sensor and it still shoots out smoke. Would anyone have an idea what it may be?
Duce Stroker is offline  
post #2 of 5 Old 10-17-2012, 07:32 AM
Member
 
Charles.knight's Avatar
 
Join Date: Sep 2012
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
How is the truck when you start it up, does it take more time and effort from your starter than usual?


Sent from my iPhone using AG Free

2004 F350 Super duty
99,500 miles
8" suspension lift
Toyo 38"s
Charles.knight is offline  
post #3 of 5 Old 10-17-2012, 08:00 AM
Premium Member
 
Snake's Avatar
 
Join Date: Mar 2008
Location: FL
Posts: 4,715
Thanks: 57
Thanked 93 Times in 75 Posts
Mentioned: 1 Post(s)
Quoted: 46 Post(s)
Feedback Score: 0 reviews
When was the last time the turbo was cleaned? Could be the vanes in the turbo sticking.

Truckless
Bulletproof Diesel www.bulletproofdiesel.com
1-A Auto Parts www.1aauto.com
Snake is offline  
post #4 of 5 Old 10-17-2012, 10:01 AM Thread Starter
Powerstroke.org Rookie
 
Duce Stroker's Avatar
 
Join Date: Oct 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It starts up no problem, starts like it always does. It sill puts out the code P0401 EGR FLW INS DET. I dont have the book to tell me what it means, i just been trying to find it via internet.

The truck has about 95,000 miles, i havent cleand the trubo, is that something i should do?
Duce Stroker is offline  
post #5 of 5 Old 10-17-2012, 11:08 AM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 62 Times in 58 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Try cleaning your ebp sensor and tube that may help some. The egr flow code can be caused by a number of sensors that are compared by the pcm to determin how the tuck is breathing so to speak. It compares intake air buy the maff;iat both of em and map and baro readings. It then compares the ebp reading [the engine exhale]. Any of those sensors are out of range can cause the egr flow code to be thrown.

The turbo not working correctly can also throw the code since it affects airflow to the engine.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome