Pulled a real dumb a** move... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-04-2012, 05:04 PM
Powerstroke.org Fanatic
 

Join Date: May 2012
Location: Fort Benning, Georgia
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Pulled a real dumb a** move...

I was putting my coolant filter in, didn't unhook the batteries first. I guess I got in a hurry.

When I was pulling the air cooler pipe on the passenger side, and hit the positive stud on top of the generator with it. It arced pretty badly. Anyhow, I removed both batteries and moved on. Finished up the project today, and the truck wont start. I am getting fuel into the bowl. I hear what I believe is the injectors clicking. I unplugged my ICP sensor and cranked for about 20 seconds, no luck.

I am getting oil pressure according to the dummy gauges on the dash.

I am getting no FICM, EOT, or SYNC on my scangaugeII. The only reading it gives me is ECT. I checked all the fuses in the fuse box under the steering wheel and they are good. Im stumped. I hope I didnt fry some expensive control module or something.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-04-2012, 05:29 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,778
Thanks: 0
Thanked 37 Times in 36 Posts
Feedback Score: 0 reviews
Did you check the FICM fuze and relay in the fuze box under the hood just forward of the degas bottle by the fender.

Without FICM or sync no injector can fire. Check all fuzes under the hood as well.
Your PCM could be fried as well or simply a fuze or relay. Near the back of the owners manual is a chart of the fuze boxes.
Reply With Quote Quick reply to this message
  #3  
Old 08-04-2012, 06:16 PM
Powerstroke.org Fanatic
 

Join Date: May 2012
Location: Fort Benning, Georgia
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
OK, checked those relays and fuses you were talking about. They all seem good, but Im going to buy 2 new relays tomorrow. I now have 48.5v showing up for FICM power and my EOT and ECT's are reading. Obviously I dont have SYNC yet because its not running. I think I may just be having the same no start issue I was having before.

Question though, I remember seeing on here before that if you unhook the batteries for any lenght of time, you need to cycle the key in a certain pattern before it will start again, something like turn it to on, wait 5 seconds, turn it off, turn it back to on again, wait 5 seconds then back offf. Then start it. Anyone heard of this before?
Reply With Quote Quick reply to this message
  #4  
Old 08-04-2012, 09:32 PM
Powerstroke.org Fanatic
 

Join Date: May 2012
Location: Fort Benning, Georgia
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
TTT............
Reply With Quote Quick reply to this message
  #5  
Old 08-05-2012, 01:33 AM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
I had my batteries out of my truck for 3 days while I was recharging them and desulfurizing them (internal reconditioning) and I just stuck them back in the truck and fired her right up no problems.
Reply With Quote Quick reply to this message
  #6  
Old 08-05-2012, 11:17 AM
Powerstroke.org Fanatic
 

Join Date: May 2012
Location: Fort Benning, Georgia
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Just an update. The scangauge says no codes have been thrown.

ICP is 870 while cranking
IPR stays blank both with KOEO and while cranking.
Reply With Quote Quick reply to this message
  #7  
Old 08-05-2012, 01:48 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
I know for a fact there are about 4 fusible links on the positive battery cable. Not sure that could be your problem. Not sure you are going to see ipr values if its not running.




Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #8  
Old 08-05-2012, 01:58 PM
Powerstroke.org Fanatic
 

Join Date: May 2012
Location: Fort Benning, Georgia
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Thanks. Ive been looking for fusable links most of the afternoon. I havent found 1 lol. Im gonna keep plugging away at it. I may throw a FICM relay in it just for sh*ts and giggles. I have no idea how to test the relays.
Reply With Quote Quick reply to this message
  #9  
Old 08-05-2012, 02:33 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Let me see of I can show a pic.[IMG][/IMG]

Sent from my phone that somebody didn't help me get.

Last edited by southend; 08-05-2012 at 02:39 PM.
Reply With Quote Quick reply to this message
  #10  
Old 08-05-2012, 02:41 PM
Powerstroke.org Fanatic
 

Join Date: May 2012
Location: Fort Benning, Georgia
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Oh, I had my hands all over that trying to move it so I could find fusable links LOL!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:49 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors