6.0l no boost - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-28-2012, 02:52 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.0l no boost

new to the forum. have a 2005 f250 superduty with the following:

-egr update
-ficm update
-stc fitting replaced
-new egr
-66k miles
-oil changed every 3-4k
-sct tsx performance tune

was running fine down the highway today at about 50mph barely on the throttle. went to pass and pushed down on the accelerator pedal about 1/4 throttle and it felt like the engine popped/hicupped and then no boost. pulled over and checked CAC boots but everything appeared okay. limped vehicle home and noticed different colors of smoke (dark and light; sorry, i'm a little colorblind) when i pushed on the accelerator; more smoke with more throttle. check engine light has not come on. pulled out the egr but it looked very good. i'm thinking a turbo issue but with the low miles not sure. also, hoping the suddenness of the problem may be a sign of something. any help would be appreciated. also checked map sensor hose but it looked okay.

jeff
Reply With Quote
scottbilt95 is offline  
post #2 of 4 Old 07-28-2012, 06:07 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
exhaust flex joint cracked, cac boots(they are hard to inspect in the truck), cracked cac. Imo

Sent from my SCH-I500

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #3 of 4 Old 08-07-2012, 07:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
problem found

turbo impeller shaft snapped in the exhaust side. just for grins the broken piece augered itself into the downpipe. disappointing....... much thanks for the advice.

jeff
scottbilt95 is offline  
post #4 of 4 Old 08-07-2012, 08:10 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by scottbilt95 View Post
turbo impeller shaft snapped in the exhaust side. just for grins the broken piece augered itself into the downpipe. disappointing....... much thanks for the advice.

jeff
That will do it, hope you get it going.

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome