Bad injectors? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-25-2012, 02:56 AM Thread Starter
Powerstroke.org Fanatic
 
07PSD's Avatar
 
Join Date: Mar 2011
Location: alden, NY
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad injectors?

The dealer told me I need 2 injectors. I did a resistance test and came up with .7-.9 ohms on all 16 coils. Is there another way for injectors to fail electronically?

1996 f-250 4x4 auto, eclb. 2.25" PMF RSK, v codes, D60, 4" tb, 6637, Tru Cool 40k, 08 front bumper, 18x9.5 AR Mojave w/ 33x12.5 Atturo MT
1998.5 2500 ecsb 2wd NV4500, 100's, HE351, Adrenaline pv2, DTT Assassin, Banks intake horn, BHAF, Autometer Cobalts, 4" tb to 7" miter, slipping stock clutch.
07PSD is offline  
post #2 of 6 Old 07-25-2012, 08:37 AM
Premium Member
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Maybe indirectly, check this out...........Why you shouldn't drive around with injector codes! .4-.6 ohm at ambient is normal. What made you get this checked out? Symtoms? Codes.

Sent from my SCH-I500

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #3 of 6 Old 07-25-2012, 10:53 AM Thread Starter
Powerstroke.org Fanatic
 
07PSD's Avatar
 
Join Date: Mar 2011
Location: alden, NY
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I read that a couple days ago. The engine was still warm when I checked them yesterday. I also read somewhere else that .8 is normal. Read my other thread called "crank but no start" I have all the problems listed in there.

1996 f-250 4x4 auto, eclb. 2.25" PMF RSK, v codes, D60, 4" tb, 6637, Tru Cool 40k, 08 front bumper, 18x9.5 AR Mojave w/ 33x12.5 Atturo MT
1998.5 2500 ecsb 2wd NV4500, 100's, HE351, Adrenaline pv2, DTT Assassin, Banks intake horn, BHAF, Autometer Cobalts, 4" tb to 7" miter, slipping stock clutch.
07PSD is offline  
post #4 of 6 Old 07-25-2012, 12:04 PM
Premium Member
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Ok, well your numbers are probably ok. But if in fact you also have a screw that fell out, your coil could not move the spool valve. You may need to pull the valve covers.

Sent from my SCH-I500

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #5 of 6 Old 07-25-2012, 02:47 PM Thread Starter
Powerstroke.org Fanatic
 
07PSD's Avatar
 
Join Date: Mar 2011
Location: alden, NY
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya I gotta at least pull the driver side off cause I pushed the plug inside when I went to plug the harness back in. I'd be working on it right now but I have community service lol

1996 f-250 4x4 auto, eclb. 2.25" PMF RSK, v codes, D60, 4" tb, 6637, Tru Cool 40k, 08 front bumper, 18x9.5 AR Mojave w/ 33x12.5 Atturo MT
1998.5 2500 ecsb 2wd NV4500, 100's, HE351, Adrenaline pv2, DTT Assassin, Banks intake horn, BHAF, Autometer Cobalts, 4" tb to 7" miter, slipping stock clutch.
07PSD is offline  
post #6 of 6 Old 07-25-2012, 02:58 PM
Premium Member
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by 07PSD View Post
Ya I gotta at least pull the driver side off cause I pushed the plug inside when I went to plug the harness back in. I'd be working on it right now but I have community service lol
Geeez..... lol, well thanks for your service to the community. Lol

Sent from my SCH-I500

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome