'03 poor acceleration - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-17-2012, 03:51 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2011
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
'03 poor acceleration

My truck is very sluggish from a dead stop. It will slowly gain speed and then all of the sudden takes off like a rocket. The turbo vanes are clean and working properly. This morning before departing for work, I unplugged the MAP sensor connector to see if it would make a difference. With the MAP unplugged it drives great, spools well, and has all kinds of power. I plugged the MAP sensor back in, and it reads around 13.9 at idle on the Scan Guage. It also went back to being a slouch. I recently removed my EBP sensor and cleaned the sensor and tube with carb & choke cleaner. I tried viewing my EBP sensor with the scan guage, but it won't show a value for it. Can you view EBP data on an '03? I'm not sure if it could be a EBP or MAP sensor that is causing my issue?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-17-2012, 04:11 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Ebp is disabled on 03-04, IIRC. Did you try to clean the map sensor hose, check for cracks?

Sent from my SCH-I500
Reply With Quote Quick reply to this message
  #3  
Old 07-17-2012, 04:26 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2011
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes, I removed the hose from the sensor and manifold and checked to make sure it wasn't plugged, cracked, torn. It was in good shape.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors