Coolant Leak...HELP?!? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2012, 07:12 AM
Powerstroke.org Fanatic
 

Join Date: Feb 2009
Posts: 138
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Coolant Leak...HELP?!?

I recently developed a coolant leak on my '04 w/ 160K miles. I've already replaced the Degas bottle, oil cooler and installed an EGR delete kit. Until just a few days ago, I could tell I was losing coolant, but have been completely unable to find a leak anywhere. I thought it might be head gaskets, but there is no coolant in the oil and no drip from the exhaust. No oil in coolant either. Three days ago, I noticed a drip from the front end when I first kill the truck. It stops after only a few minutes. I crawled underneath and saw a drop running from the top of the harmonic balancer. If this was my old 7.3 or an old gas burner, I'd automatically assume it was a leaky water pump. I leared a long time ago not to assume anything on a 6.0L and to seek advice before tearing into anything. I can't see any leaky hoses or anything else and I'm starting to get really frustrated.

Any suggestions? PLEASE?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors