Coolant Leak...HELP?!? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-09-2012, 08:12 AM Thread Starter Fanatic
Join Date: Feb 2009
Posts: 148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Coolant Leak...HELP?!?

I recently developed a coolant leak on my '04 w/ 160K miles. I've already replaced the Degas bottle, oil cooler and installed an EGR delete kit. Until just a few days ago, I could tell I was losing coolant, but have been completely unable to find a leak anywhere. I thought it might be head gaskets, but there is no coolant in the oil and no drip from the exhaust. No oil in coolant either. Three days ago, I noticed a drip from the front end when I first kill the truck. It stops after only a few minutes. I crawled underneath and saw a drop running from the top of the harmonic balancer. If this was my old 7.3 or an old gas burner, I'd automatically assume it was a leaky water pump. I leared a long time ago not to assume anything on a 6.0L and to seek advice before tearing into anything. I can't see any leaky hoses or anything else and I'm starting to get really frustrated.

Any suggestions? PLEASE?
lmorgan is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome