2007 6.0 died at a stoplight, now no start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-2012, 09:06 AM
Powerstroke.org Rookie
 

Join Date: May 2012
Location: Wellington, CO
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2007 6.0 died at a stoplight, now no start

SO i have an issue with my bone stock 2007 6.0 liter...stopped at one light, and i couldn't get it to accelerate until i revved it up in neutral, then put it back in drive and i was able to go. shortly after, (less than two miles), i stopped at another light and it just shut off. It will crank, and try to fire for about a second, then stops firing.

All this happened after four hours of steady highway driving, pulling a 7000 pound enclosed trailer at about 75 mph. I didn't overheat, no leaks noticeable, no odd smells or noises.

I got it towed to a shop in rapid city, south dakota called Rapid Diesel. I had to leave it there and rent a pickup to keep going, i work in the oilfield as a drilling consultant and was running behind to a well, so i had no other option but to get going.

An ideas about what is wrong, i need to know quick so i can get it fixed and back on the road, and to make sure this shop doesnt blow smoke up my ***.

Again, this is a bone stock 2007 6.0 liter, auto transmission, 64000 miles, 4x4 xlt.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-06-2012, 09:12 AM
Premium Member
 

Join Date: Oct 2010
Posts: 1,890
Thanks: 0
Thanked 14 Times in 13 Posts
Feedback Score: 0 reviews
HPOP fitting or maybe a FICM issue.
Reply With Quote Quick reply to this message
  #3  
Old 07-06-2012, 09:21 AM
Powerstroke.org Rookie
 

Join Date: May 2012
Location: Wellington, CO
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks a bunch for the quick reply -

HPOP fittings, do you mean the ICP, IPR, and STC fittings?
Reply With Quote Quick reply to this message
  #4  
Old 07-06-2012, 09:39 AM
Premium Member
 

Join Date: Oct 2010
Posts: 1,890
Thanks: 0
Thanked 14 Times in 13 Posts
Feedback Score: 0 reviews
Yep STC fitting... If the truck dies in flight then its most likely the STC fitting.
Reply With Quote Quick reply to this message
  #5  
Old 07-07-2012, 11:02 AM
Powerstroke.org Rookie
 

Join Date: May 2012
Location: Wellington, CO
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for your help, shop called back last night. They replaced the ICP sensor and it started right up.
Reply With Quote Quick reply to this message
  #6  
Old 07-07-2012, 12:23 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,111
Thanks: 17
Thanked 65 Times in 59 Posts
Feedback Score: 3 reviews
If it's an oil leak it may restart cold. Hopefully they didn't just throw an ICP sensor at it.
Reply With Quote Quick reply to this message
  #7  
Old 07-07-2012, 03:09 PM
Powerstroke.org Rookie
 

Join Date: May 2012
Location: Wellington, CO
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Before the repair it wouldn't start hot, cold, warm, or anywhere in between. Batteries were non-issue, I even tried jumping it in case the voltage was too low.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:46 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors