2004 6.0L Surging, Lunging, Very low RPMs.... Please Help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-24-2012, 04:56 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 2004 6.0L Surging, Lunging, Very low RPMs.... Please Help

Hey everyone im very new to this thread this is my 1st post here. I have a 2004 6.0l and im having some trouble with it. I have a egr delete, exhaust, intake, edge evo tuner.

As im driving hot or cool outside the truck will start acting really weird, Idling very low, picking back up then surging very bad. Sitting in traffic with my foot on the brake the truck wants to take off. almost feels like it loads up with fuel and goes. Sometimes wanting to die then catches back up and idles with almost a "lope" affect. there is no codes coming up at all !!!! if anyone can help plz give me ur 2cents. its my DD
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-25-2012, 03:49 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bump..... Anyone have a idea? i have searched but the only thing i can think of is the ICP sensor ? can anyone tell me if the ICP, FICM, were going bad or how to check them ? thanks everyone
Reply With Quote Quick reply to this message
  #3  
Old 06-25-2012, 12:40 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Come on guys help me out I'm lost
Reply With Quote Quick reply to this message
  #4  
Old 06-25-2012, 06:10 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So this hasent happened to anyone?
Reply With Quote Quick reply to this message
  #5  
Old 06-25-2012, 06:15 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Actually I have heard of this before, can't remember what it was. Seriously try google, most the time it will suggest from these forums. Sorry im no help.

Sent from my SCH-I500
Reply With Quote Quick reply to this message
  #6  
Old 06-25-2012, 06:50 PM
Powerstroke.org Rookie
 

Join Date: Jul 2011
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im no expert but remember hearing this being related to ICP sensor
Reply With Quote Quick reply to this message
  #7  
Old 06-25-2012, 07:28 PM
Premium Member


 

Join Date: Dec 2010
Location: Carthage
Posts: 303
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by zachyfarms View Post
Im no expert but remember hearing this being related to ICP sensor
I second that! Although I didnt have all the same symptoms (wanting to take off), When I changed out my ICP it did clear up the loping!
Reply With Quote Quick reply to this message
  #8  
Old 06-25-2012, 08:11 PM
Premium Member
 

Join Date: Oct 2007
Location: Rio Rancho NM
Posts: 587
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Get a Scangauge II and monitor the IPR & ICP that will show you what is going on and check the FICM voltage too. If you want to throw parts at it replace the IPR & ICP sensors.
Reply With Quote Quick reply to this message
  #9  
Old 06-26-2012, 03:51 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok ill start with testing those anyone kno what the voltage should be?
Reply With Quote Quick reply to this message
  #10  
Old 06-26-2012, 05:21 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok guys i cought the truck in action on my smart phone. i took a vidoe is there a way to post the video on here so somebody can see it ? if so help me put on how to post it plz
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors