FICM PROBLEM PLEASE HELP! Straight wire 12v power and it runs? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-15-2012, 07:38 PM Thread Starter Rookie
Join Date: Jun 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FICM PROBLEM PLEASE HELP! Straight wire 12v power and it runs?

I have my newest project almost done a 06 f250 XL 4x4 6.0, I bought it as a theft recovery and have replaced pretty much every drivetrain part including fuse boxes, steering column, etc. I got power to ficm relay but no power to ficm. I took a wire with to gator clips and connected one side to pos battery and one side to the green wire comming from the 12 wire harness clip by the fuse box that powers the ficm and it fires right up! I cranked it like that about 5 times and ran great. Then I tried again and it burnt the small wire in half. My question is if I use a bigger wire and wire 12volt power straight to that green wire will it work? This truck has got me goin nuts! Any help is greatly appreciated!
Strokeon6s is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome