Please help! Coolant puke!! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-11-2012, 04:29 PM Thread Starter
Compression Ignition Addict
Kyleu890's Avatar
Join Date: Jan 2012
Location: St. Louis/ Around Chicago
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Please help! Coolant puke!!

Hey guys and girls, thanks in advance for any help advice. I have an 04 CCSB straight pipes with a coolant filter and that's all. Since I bought the I have had no problems with coolant issues, not loosing any, no white smoke after its been sitting. Deltas vary with speed, 60-65/7-9, 70-75/10-12, 80+/14-16. Yesterday I put about 500 miles on the truck and unfortunately I was late for a concert about 3 hours away so she was workin hard most of the trip running about 80 through some missouri hills. I went to change the coolant filter today and I see puke from cap :-(. She runs great no loss of power and like I said no smoke/ not loosing coolant. What could cause this? Looked under degas cap, nothing floating just worthless gold! Oh and yesterday on the trip my ect/eot were around 200-204/206-216 at 80/80+ mph. Please help!

Sent from my Autoguide iPhone app

04 ccsb f350 little red rip! Previous truck

05 ccsb f250 currently bone stock no plans to change it.
Kyleu890 is offline  
Sponsored Links
post #2 of 3 Old 06-11-2012, 05:03 PM
Compression Ignition Addict
T diesel's Avatar
Join Date: Jul 2011
Posts: 331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 17
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
I'd replace the cap first.
OEM only.

2013 F-250 lariat scsb FX4.
6.2. 3.73 lockers. Rear wheel liners.
Camper package. Pullrite 18K lb Superslide, Line X sprayed bed.
Krown rust protected.
"That which can be asserted without evidence, can be dismissed without evidence"
- Christopher Hitchens
T diesel is offline  
post #3 of 3 Old 06-11-2012, 05:33 PM
Compression Ignition Addict
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 62 Times in 58 Posts
Feedback Score: 0 reviews
Since you were running it hard at 80/80+ and you reach 16psi it would be normal to vent since the cap is supposed to vent at 16 psi.

It would be normal under heavy use/load to reach those pressures for a short period of time, long as it doesn't stay that way. How much trash have you been getting out of your coolant filter? You may have some restriction of your oil cooler. A flush may be in order.

Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome