truck throws code after 3hrs of towing? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-09-2012, 03:14 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Location: Shallowater, Texas
Posts: 456
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
truck throws code after 3hrs of towing?

My truck threw a P0404 code, and check engine light, after towing my fifth wheel trailer for 3 hrs. All the temps were fine, got to the rv park, unhooked, parked truck. The next day, left the rv park in the truck (no trailer), no check engine light, but can't clear stored code. Three days later, left rv park with fifth wheel, after three hours towing check engine light comes on again, i guess its the same code, since i could not clear the code, no new codes for sure, just the P0404 code.
I had installed the BPD oil and egr cooler about 3k miles ago and cleaned the egr valve, truck has 103,000miles on it, and i believe it has the original egr valve.
What to do?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-09-2012, 06:11 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i would replace valve and try that good luck
Reply With Quote Quick reply to this message
  #3  
Old 06-11-2012, 03:53 AM
Compression Ignition Addict
 

Join Date: Apr 2012
Location: Shallowater, Texas
Posts: 456
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump, bump, anybody else?
Reply With Quote Quick reply to this message
  #4  
Old 06-11-2012, 06:03 AM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 16,719
Thanks: 13
Thanked 11 Times in 9 Posts
Feedback Score: 4 reviews
I would agree. It sounds like the EGR valve was blown open setting the CEL... You might want to pull the valve out and verify it. Since cleaning it didn't seem to work, you might consider getting a new one.
Reply With Quote Quick reply to this message
  #5  
Old 06-11-2012, 11:03 AM
Compression Ignition Addict
 

Join Date: Apr 2012
Location: Shallowater, Texas
Posts: 456
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i talked to Andrew at Bullet proof diesel, he seems to think the egr valve is bad, so that makes three people. i am gonna replace the egr valve.
Reply With Quote Quick reply to this message
  #6  
Old 09-03-2012, 06:18 AM
Member
 

Join Date: Jul 2012
Location: Edmond, OK
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to freebass
Its not the EGR...........Having the same issue and thats all these guys can come up with. Spend money on a guess
Reply With Quote Quick reply to this message
  #7  
Old 09-03-2012, 07:04 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,275
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Ok Freebass whats your diagnosis and why?
Reply With Quote Quick reply to this message
  #8  
Old 09-03-2012, 07:13 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 6,274
Thanks: 34
Thanked 59 Times in 57 Posts
Feedback Score: 0 reviews
ya can always try to clean the EGR as first try and a free repair if it works

and it does work for many
Reply With Quote Quick reply to this message
  #9  
Old 09-03-2012, 07:48 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,275
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
P0404 C* Exhaust Gas Recirculation Control Circuit
Range/Performance
+/- 0.10 EGRP error from commanded to actual EGRP during
normal driving conditions.
Faulty EGR sensor, valve or PCM integrity of EGR position circuit

This is the code definition. Since you changed the valve it is probably a wireing issue.
I assume that the egr sensor is no longer sold by itself since every egr I have ordered in the last 8 yrs has come complete with sensor.
Reply With Quote Quick reply to this message
  #10  
Old 09-03-2012, 07:49 AM
Premium Member
 

Join Date: Nov 2011
Location: Riverton UT
Posts: 1,023
Thanks: 17
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
had the same issue a few months ago, new EGR valve, the only other thing it could be is a bad connection,
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors