2005 F350 fuel delivery/shifting issue? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-06-2012, 03:55 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 F350 fuel delivery/shifting issue?

Hi all. This is my first post and I'll try to keep it short. I'm having problems with what seems to be fuel delivery at low idle when coasting and getting back on the throttle in 5th gear. It doesn't seem to react until I give it quite a bit of fuel and then it kicks in after hesitating. A couple weeks ago it was doing a similar thing in any gear at any rpm but didn't respond to any more fuel and would drop to idle. I took it to the dealership and they put a new FICM in it and I'm still having problems. Fuel filters were changed 3000 miles ago. The truck is a 2005 F350 King Ranch with 4" exhaust on 37" tires.

The consensus from those that I've talked to say that you need to match the air intake (cold air kit) or chip it to keep up with the exhaust. The truck was chipped before I bought it but isn't anymore. Any help would be much appreciated! I'd rather not take it back to the dealership and spend another $1200 bucks if I don't have to.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-06-2012, 05:17 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Get a monitor, check codes. Check your fuel pressure, do you have the blue spring update?

Sent from my SCH-I500
Reply With Quote Quick reply to this message
  #3  
Old 06-06-2012, 08:09 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did have it plugged in, but it threw no codes. What is the blue spring update?
Reply With Quote Quick reply to this message
  #4  
Old 06-07-2012, 12:56 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Quote:
Originally Posted by troyor View Post
I did have it plugged in, but it threw no codes. What is the blue spring update?
Google will explain it faster than I can here.

Sent from my SCH-I500
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:34 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors