HELP....Rough runner, smokes, stalls - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-11-2012, 02:59 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy HELP....Rough runner, smokes, stalls

2004 4X4 F250 6.0 liter 100,065 miles. EGR delete kit, everything else stock. I changed the fuel filters and problem went away for 40 miles and came right back. It idles a little rough, blue or white smoke on startup. blue smoke while running, but not excessive. It will idle all day long, but if you climb a hill or get on it it will eventually stall. As soon as it stalled I turned the key off and the engine mounted filter was empty. Checked HFCM filter and replaced again with no help. drained H20 plug, no H20. Pulled bed and checked in tank pickup and it looked new. It is a plastic tank. All fuel lines look very good, internal o-rings look good. I replaced The fuel pump in the HFCM and thoroughly cleaned unit. Found some brownish mud buildup inside HFCM. Installed pressure regulator kit to boost fuel pressure, it was pretty dirty in there, I thought that was weird. After completion, problem is the same. A couple times it seemed like the engine almost hydro locked while cranking. I am almost stumped at this point, any help would be gladly appreciated!!!

Thank you,

John M.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-11-2012, 04:28 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Raleigh, NC
Posts: 3,479
Thanks: 7
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
I'm not sure about the blue smoke, that may be a separate problem. Sounds like its starving for fuel. I think a cylinder contribution test would be a good place to start. make sure you get diesel from a place that sells a lot of it. are you changing out your fuel filters every 10k miles? whats you FICM voltage?
Reply With Quote Quick reply to this message
  #3  
Old 03-11-2012, 05:06 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by atvrider93 View Post
I'm not sure about the blue smoke, that may be a separate problem. Sounds like its starving for fuel. I think a cylinder contribution test would be a good place to start. make sure you get diesel from a place that sells a lot of it. are you changing out your fuel filters every 10k miles? whats you FICM voltage?


I may be wrong but if I pull the fuel filter off of the top of the engine and it is almost out of fuel, I believe I have a lack of fuel issue. Even if my tank was full of water, obviously it wouldn't run but the fuel pump would keep that fuel filter on top the engine full of whatever liquid you had in the tank. As soon as it stalls or near stalling i shut the key off, hurry and remove the fuel filter cover to notice it is near empty. Even if my FICM voltage was low or non existant that filter should be full right? I do change filters regularly and evertime the one on the engine was full of fuel. I am no expert by any means, I am just trying my best logic and any helpfull suggestions. What do you think?
Reply With Quote Quick reply to this message
  #4  
Old 03-11-2012, 05:18 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Raleigh, NC
Posts: 3,479
Thanks: 7
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
the line could be clogged, try blowing it out
Reply With Quote Quick reply to this message
  #5  
Old 03-11-2012, 05:21 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by atvrider93 View Post
the line could be clogged, try blowing it out

I pulled all fuel lines feed and return, clean and clear
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:54 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors