Post Stud/HG questions - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-03-2012, 08:08 AM
Compression Ignition Addict
 

Join Date: May 2007
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Post Stud/HG questions

I did all the common mods when I redid my hg's. Truck has been running about 1,000mi an has been super strong. I also bought a USED 03 turbo an 5" exhaust an a SCT running the SRL+ tune. I've done some racing an like I said the truck is very strong right now. I have also been running the truck kinda hard right now. Its so much fun you can't help it.

I've noticed the boot that connects the turbo to the hotside of the intercooler is soaked with oil and the front side (not back end of the turbo) is VERY dirty.

I also have been pulling 2 codes (P2285 / P2287) pretty common now but not till about the last 250mi. My truck HAS ALWAYS skipped and farted like its doing now an I think this has always been going on new gauges just let me read them now. I think when the truck skips (maybe fuel problem but no real idea) it drops the oil pressure and the ICP pulls the code. Not sure.

Major question is the oil on the boot. The turbo is used (I did a very good cleaning before install - was told the turbo has 75,000 on it) an I've upgraded the drain tube but maybe the turbo is going? I HAVE NOT done a ccv mod and the crank case is stock now.

The highest boost I've seen is 28lbs an I'm pretty sure the back end of the turbo is tight as it is very clean back there, I'm wondering if the boot might have a small hole as I've been told it could cause the dirt all over the front of the motor. It looks soaked in oil.

Anyone have a great idea on the ICP codes that would be a big bonus. Like I said it has ALWAYS surged/farted/burped an although it was MUCH better right after the rebuild its back to normal now. I have 155,000 an the HPoP is stock on my latemodel 04

As always.... thanks for the help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:11 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors