Replaced icp, now no start! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-01-2012, 08:05 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Richlands
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Replaced icp, now no start!

I replaced my icp sensor and pigtail and now my 2003 6.0 powerstroke won't start, cranks but won't fire. Any ideas greatly appreciated!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-01-2012, 12:26 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,577
Thanks: 0
Thanked 22 Times in 21 Posts
Feedback Score: 0 reviews
First how many times and how long did you try to crank it. It can sometimes take a while to work the air out.

Second unplug the ipr and restart, if it fires up you have a bad ipr. If it doesn't you have a high pressure oil leak.

Have it scanned live data while cranking see whats going on.
Reply With Quote Quick reply to this message
  #3  
Old 03-01-2012, 02:00 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Richlands
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks alot ill, I've cranked it alot with no luck, I will try unplugging the irp and try to restart, let ya know how it goes!
Reply With Quote Quick reply to this message
  #4  
Old 03-01-2012, 02:21 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Richlands
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tried cranking it for about 20 seconds with it unplugged with no luck, so what gives, it started before I removed the icp sensor and now won't do anything but crank.
Reply With Quote Quick reply to this message
  #5  
Old 03-01-2012, 02:29 PM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 17,984
Thanks: 74
Thanked 118 Times in 109 Posts
Feedback Score: 5 reviews
Check your voltage...
Reply With Quote Quick reply to this message
  #6  
Old 03-01-2012, 06:56 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
why did you change the sensor, was the plug oily? The plug may have simply failed when you removed it the last time.

edit: oops, you changed the pigtail. recheck it?
Reply With Quote Quick reply to this message
  #7  
Old 03-02-2012, 12:35 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Richlands
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was leaking oil sown the back of engine, I've checked my wiring and even reconnected the old pig tail with no start.
Reply With Quote Quick reply to this message
  #8  
Old 03-04-2012, 04:26 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Richlands
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
update, i pulled the DTC's and got these. P0603- Internal CTRL MOD KAM error. P0670- Glow plug CTRL circ error, P0683- Glow plug ctrl mod to pcm comm circ, P1000- checks not complete, P2289- injection ctrl pressure to high- engine off, P2623- CTRl pressure regulator, circ/open. any ideas how what to do next to get it to start and back on the road greatly appreciated!

Last edited by 2003powerstroker; 03-04-2012 at 04:33 AM.
Reply With Quote Quick reply to this message
  #9  
Old 03-04-2012, 07:18 AM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,267
Thanks: 22
Thanked 77 Times in 68 Posts
Feedback Score: 4 reviews
P2623 is an IPR circuit code and P2289 is an ICP circuit code. Unfortunately these codes could have set when you were cranking with the connectors unplugged and that doesn't really tell us anything.

can you clear the codes and try cranking it again to see which ones return?

Did you have the glow plug control module unplugged for any reason? It's possible that's the reason for your no start also
Reply With Quote Quick reply to this message
  #10  
Old 03-04-2012, 07:20 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Richlands
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I cleared them and the one that returned was P2289, along with P1000
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors