6.0 Missing. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2012, 05:02 PM
Member
 

Join Date: Nov 2010
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 Missing.

Ok guys I been noticing my truck sort of skipping/missing lately. Right off the bat I wanna say it has something to do with fuel supply. Maybe fuel pump, or injector or something along those lines im not sure. But its just a constant skip/miss going down the road. It does it really bad when the truck is cold. I had my FICM repaired by Ed@Ficmrepair.com not to long ago, so maybe it isn't the Ficm again. But I was just gonna see if anyone else has experienced this problem and found the solution. Soo if you have any ideas on what it may be please post it.

thanks,
Cameron Rogers
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-26-2012, 05:30 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My truck is currently doing the same thing after I did EGR delete, updated turbo drain tube and fuel pressure regulator spring. I have ruled out everything except the IPR valve. If it is partially plugged I have found that it can cause this issue. I will be pulling it tomorrow to see what I find.

Sent from my DROIDX using AutoGuide.com App
Reply With Quote Quick reply to this message
  #3  
Old 02-26-2012, 05:40 PM
Member
 

Join Date: Nov 2010
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by TowGuy2003.6.0 View Post
My truck is currently doing the same thing after I did EGR delete, updated turbo drain tube and fuel pressure regulator spring. I have ruled out everything except the IPR valve. If it is partially plugged I have found that it can cause this issue. I will be pulling it tomorrow to see what I find.

Sent from my DROIDX using AutoGuide.com App

Dont mean to sound like a dumb@$$ but what is an IPR valve?
Reply With Quote Quick reply to this message
  #4  
Old 02-26-2012, 05:50 PM
Powerstroke.org Rookie
 

Join Date: Jan 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
IPR is injector pressure regulator.

Missing could be several things. You need to test it for DTCs or else you will be gambling money. Could be a cylinder contribution issue/ or injector. Which is cheaper than FICM etc.

Find DTCs (diagnostic trouble codes) and we can point you in right direction.

Make sure ficm connectors are tight. Injector connectors are tight. Try and disconnect batteries for a while and plug them back in.
Reply With Quote Quick reply to this message
  #5  
Old 02-26-2012, 05:52 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It doesn't cost anything to pull it out and look. If you don't have access to check codes. Also check to make sure the map sensor bung on the intake manifold isn't plugged. Easy things to check.

Sent from my DROIDX using AutoGuide.com App
Reply With Quote Quick reply to this message
  #6  
Old 02-26-2012, 05:55 PM
Member
 

Join Date: Nov 2010
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by nelapse View Post
IPR is injector pressure regulator.

Missing could be several things. You need to test it for DTCs or else you will be gambling money. Could be a cylinder contribution issue/ or injector. Which is cheaper than FICM etc.

Find DTCs (diagnostic trouble codes) and we can point you in right direction.

Make sure ficm connectors are tight. Injector connectors are tight. Try and disconnect batteries for a while and plug them back in.
I have had the FICM repaired and updated with 3 year warranty, so if it is messed up its free, but I will check the connections to make sure everything is plugged in good. I remember reading somewhere that one of the plugs on the FICM was a pita.

And I will probably be hooking the Snap-On Modis to it tomorrow. So maybe we will be able to figure something out then.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors