Just bought the truck an now this.... - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 51 Old 02-21-2012, 06:34 PM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
Just bought the truck an now this....

So went under the hood today and saw this... I am immediately thinking my motor is going to blow up after reading through the forum.. The truck only has 54K on it!

Should I still continue with all my maintenance (bought the truck friday so doing all fluids: oil, trans, fr/rear diff, transfer case and adding Coolant filter) or is it time to start looking at remote oil coolers, bulletproof egr and studs? will my coolant filter help whatever's causing this?

No fluid anywhere, just stained... The guy i bought it from said the turbo was replaced under warranty.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
Sponsored Links
Advertisement
 
post #2 of 51 Old 02-21-2012, 06:40 PM
Powerstroke.org Fanatic
 
jason's Avatar
 
Join Date: Mar 2006
Location: SOUTH CAROLINA
Posts: 120
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Welcome to being the owner of a 6.0 powerstroke. LOL. hey i feel for you, mines doin it too. i already have a egr cooler delete, my coolant pressure test is normal , and i'm fixing to put a new oil cooler in mine this weekend. hope it;s not you're head gaskets. are you noticing any steamy or whie smoke coming from your exhaust??? if so maybe it's just your EGR cooler. If so , replace your EGR and Oil cooler at the same time. I didn't , and wish i would have.
jason is offline  
post #3 of 51 Old 02-21-2012, 06:54 PM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
hmmm... no white smoke at all. I'm just very frustrated as i just bought this truck! Last Friday in fact. Don't really feel like throwing 3K at it right off the bat


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
post #4 of 51 Old 02-21-2012, 07:02 PM
My 6OH Hates Me


 
mudrunninpig's Avatar
 
Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,851
Thanks: 8
Thanked 27 Times in 26 Posts
Mentioned: 1 Post(s)
Quoted: 24 Post(s)
Feedback Score: 1 reviews
hmmmmmm Its hard to tell by the pic, but it looks like your fluids are WAY over full. That bottle should be around 1/2 to a little less than half full.

Mike





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"The Iron Pig"



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mudrunninpig is offline  
post #5 of 51 Old 02-21-2012, 07:04 PM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
so should i drain some coolant, clean the bottle and see if it happens again before i get worried?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
post #6 of 51 Old 02-21-2012, 07:07 PM
My 6OH Hates Me


 
mudrunninpig's Avatar
 
Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,851
Thanks: 8
Thanked 27 Times in 26 Posts
Mentioned: 1 Post(s)
Quoted: 24 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by OCVeloMan View Post
so should i drain some coolant, clean the bottle and see if it happens again before i get worried?
yes, absolutly. dont get freaked out too soon. With the new bottles, the old MIN line is the new MAX line. put the level a little lower than the min line. clean it up and see if it happens again. If it does, pull the egr valve and see if it is wet. if it is then your cooler is bad. keep us updated on the symptoms.

Mike





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"The Iron Pig"



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mudrunninpig is offline  
post #7 of 51 Old 02-21-2012, 07:26 PM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
will do! thanks!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
post #8 of 51 Old 02-22-2012, 06:12 PM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
Pumped out around 3/4 gallon of coolant, got a new cap and cleaned up the tank. Round two begins! Also, changed front and rear diff and transfer case fluids. Oil/trans tomorrow and coolant filter friday. I'll get this truck in good shape if it kills me! lol



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
post #9 of 51 Old 02-26-2012, 11:59 AM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
Checked again today and, despite driving the truck pretty hard, no coolant residue! My Edge Insight CTS is in the mail along with my coolant filter so I'll update this as things progress and I know more.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
post #10 of 51 Old 03-01-2012, 02:00 PM Thread Starter
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,799
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
Edge insight in!

Trans Temp, averaged 154*
EOT: Averaged 195-198
ECT: Averaged 190-192
FICM Voltage: 48.5 Avg

Sounds stout to me! Just waiting on the coolant filter now!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome