ICP pressure/hard starts w/video - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2012, 01:48 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ICP pressure/hard starts w/video

I have a hard start hot that I am tracing down. I did a air test today without cycling the ICP and did hear a fair amount of air leaking on the right/passenger bank when I took the oil fill cap off and stuck a tube down it. I also heard a little down by the HPOP, but not much there.

Anyway I am going to be taking off the valve covers soon, and will recheck the air test. I believe I have a bad o-ring on the top of an injector. I just replaced the stand pipes and dummy tubes not too long ago.

So here is what I have a question about I noticed today that when I'm driving and running about 2000 rpms that I am around the 1300 psi area but when I get on it that number drops. I got 2 videos of this today. If you watch the videos the ICP pressure is on the left of the CTS and the ICP voltage is on the right. Watch the numbers as I accelerate hardish. What is causing this?





Link to old post
no-start-hot-new-stand-pipes-dummy-plugs
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-22-2012, 05:29 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone have any ideas?
Reply With Quote Quick reply to this message
  #3  
Old 02-23-2012, 06:00 PM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Deltona
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need to see what the ICP is hot cranking hard start
Reply With Quote Quick reply to this message
  #4  
Old 02-26-2012, 07:50 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bueller, Bueller, anyone


No one else has any insight?
Reply With Quote Quick reply to this message
  #5  
Old 02-26-2012, 11:09 AM
Compression Ignition Addict
 

Join Date: May 2010
Location: Springport MI
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I would get the engine warm and pull the valve covers, crank the engine and look for oil leaks. I have a 03 but pretty much the same hp oil system check out the thread in my signature.
Reply With Quote Quick reply to this message
  #6  
Old 02-28-2012, 12:01 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Here is a short video of the NO start hot.

Reply With Quote Quick reply to this message
  #7  
Old 02-28-2012, 02:49 PM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Deltona
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you do the stc fitting on the hpop
Reply With Quote Quick reply to this message
  #8  
Old 02-28-2012, 03:38 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
STC was done about a year and a half ago.
Reply With Quote Quick reply to this message
  #9  
Old 02-28-2012, 04:04 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Springport MI
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by anmetcalf View Post
STC was done about a year and a half ago.
Injector o rings maybe? I would pull the valve covers when it is hot and see if you can see one leaking.
Reply With Quote Quick reply to this message
  #10  
Old 02-28-2012, 05:37 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I believe it is an injector O-ring. But I didn't think that an o-ring along would show me such loss of pressure at the ICP sensor under hard accelerations. My belief now is that it is an o-ring on the passenger side. Thus cutting the amount of pressure the ICP sensor sees.

My dilemma now is that I have a bad injector/s and want to know which one before I open her up so that I'm not opening, closing, then opening.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:51 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors