Put new injectors in now can get it to start need help please - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-04-2012, 03:29 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Put new injectors in now can get it to start need help please

Hi I just put in all new injector on the passager side. Put everything back together now can not get the truck to stay running. I have let the fuel pump run by turning the key over 6 time for about 30 second truck starts runs for a min then dies. I have done this a couple times same result. So I check the fuel filter on the engine to make my fuel pump is working. The pump will fill up it up up the top back on truck will start and then die after a min or so. Take the cap back off the filter and all the fuel is goes. Can let it feel back up put cap back on it, truck will start then die with same results in the fuel filter. Is my fuel pump shot or does anyone have any suggestions. The truck is a 04 f250 6.0 with 105k. Thanks
kwix55 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome