2003 6.0 cuts out going down the road - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-13-2011, 10:05 AM
Premium Member
 

Join Date: Jan 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 6.0 cuts out going down the road

My truck has been good to me until now. 2 wks ago had 3 injectors replaced. It ran fine for a couple days then it just woldn't start one morning (spin but no fire). Changed the fuel filters, and watched the top bowl fill...fuel pump should be ok. then I noticed there was no sound....assumed a bad FICM, bbut in the middle of looking at that I found the Injector Relay was just clicking...wiggled it around and I got the injsctors to light off and she started right up.......Now it intermittently dies out going down the road (seems electrical not fuel) does anyone know if the injector relay could cause it to do this, or do I have 1 more gremlin to fight.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-14-2011, 08:14 AM
Premium Member
 

Join Date: Jan 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
12/14 update. I took the cover off of the FICM power relay and its not kicking on. Looking through some other sites it seems as though I don't have either a ground signal (MPR) comming out of the FICM, or I have a break in the power wire that feeds the module and the relay. Does anyone have any advice for me yet?
Reply With Quote Quick reply to this message
  #3  
Old 12-14-2011, 08:21 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Get a multimeter and check the circuits. Might be as simple as a bad relay... If you have power at one connector and continuity to ground on the other and it isn't engaging then you have a bad relay... If wiggling it around made it start workin I would also look at the connectors where the wires go into the relay plug as they may be corroded or broken or spread out so that they aren't making a good contact to the relay


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #4  
Old 12-15-2011, 04:03 PM
Premium Member
 

Join Date: Jan 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
12/15 update...replaced the FICM relay...not a damn thing. I've plugged my autotap in 20 times not 1 DTC.... well team Powerstroke, I'm out of ideas....looking for yours.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors