Losing Power While Driving - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 07-06-2011, 02:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Losing Power While Driving

my 2005 6.0 liter loses boost and power after i let off the fuel and give it fuel again while driving down the highway, could it be my EGR or Injector?
ben_KingRanch is offline  
post #2 of 8 Old 07-06-2011, 03:26 AM
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Maryland
Posts: 355
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Do you have gauges. Check how much boost rye.making . The turbo vains might be sticking
mx730md is offline  
post #3 of 8 Old 07-06-2011, 02:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
my turbo is only putting out about 22psi and its a factory turbo not an aftermarket one,
ben_KingRanch is offline  
post #4 of 8 Old 07-28-2011, 08:26 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
turns out it was my EGR valve, it was sticking open
ben_KingRanch is offline  
post #5 of 8 Old 07-28-2011, 05:30 PM
Member
 
Join Date: Mar 2008
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by ben_KingRanch View Post
turns out it was my EGR valve, it was sticking open
Did you also get black smoke out of the exhaust when the loss of power occured?
Toptech is offline  
post #6 of 8 Old 07-28-2011, 05:44 PM
Powerstroke.org Rookie
 
Clapsrm's Avatar
 
Join Date: Feb 2010
Location: LI
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine was doing the same thing. Ended up being EGR valve staying open. Got it changed, now the same thing is happening again. I read that shtuff can accumulate in the pipes and clog even a brand new valve. I have to bring mine in again.
Clapsrm is offline  
post #7 of 8 Old 08-04-2011, 07:31 AM
Powerstroke.org Rookie
 
Join Date: Jul 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My all stock 05 doe sthe same thing, If you let off the gas and get back in it, it will not spool back up. I cant get it to run over 5lbs anymore. Does anyone have any suggestions?
gmitchell250 is offline  
post #8 of 8 Old 09-30-2012, 04:11 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Get a new egr valve and take it in for a egr delete kit
ben_KingRanch is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome