engine skips after hard acceleration then clears after cycle engine - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-03-2011, 03:58 PM Thread Starter
Powerstroke.org Fanatic
djeasy87's Avatar
Join Date: Jun 2010
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
engine skips after hard acceleration then clears after cycle engine

I have an f350 2004 and sometimes after hard accleration it would skip. Would continue to skip until I turn it off, wait about ten seconds and turn it back on. When I turn it back on it would skip for about 5 seconds then clear up. This has happen about three times, any idea what's going on guys? tuned by idp extreme race

2004 F-350 CC FX4 5" mbrp exhaust, Studded and EGR Deleted, aFe Stage One w/ Pro Guard 7, Edge Insight, '05 Conversion, 55W Headlight HIDs
djeasy87 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome