old post=no power, new post=injector wiring harness - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-26-2011, 07:31 PM Thread Starter
Powerstroke.org Rookie
Join Date: May 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
old post=no power, new post=injector wiring harness

hey folks, i posted before regarding no boost below 2000 rpm. i am wondering if there is any way to check if it may be the injector harness. i am thinking that my problem is injector related. can i test the harness some how? is the harness able to be replaced by a non-tech (i can do just about anything, just don't have any ford special tools)
i tow a skidsteer and i am getting sick and tired of not having any bottom end boost. i know that it isn't turbo related, as i swapped turbos from another 6.0 that i know runs right.
red_loctite is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome