Injector woes - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-18-2011, 06:01 PM Thread Starter
Join Date: Feb 2011
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injector woes

Took the 2003 Excursion to shop for egr delete and some other ellective/preventative mods. Truck seemed to run pretty good with an intermitent miss in very cold temps.

Mech ran a scan and turned up bad injectors on 5 and 7. Also threw an egr code and a turbo code.

Then he did egr delete, new oil cooler w/hpop screen, clean turbo (it was badly coked and siezed), fuel pressure regulator upgrade (blue spring), coolant filter, flush/fill with elc, and replaced injectors 5 and 7.

Got it put back together and ran another scan to clear any codes and injector 4 failed both tests.

Anybody know why 4 would pass before mods and fail after? Is there anything else that might be causing the code. Mech said he rechecked connections after the scan and found the connector/pins on the injector and harness to be fine. Is this injector really bad too?

herman07 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome