idle issues - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-08-2010, 02:34 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
idle issues

hey guys,

my 05 has been giving me trouble lately. the idle jumps all around from roughly 500 to 1000 rpm. it only does this after i have driven the truck for an hour or so. everything else has been fine. no cel. i took it in to ford and they tested it out (2nd dealer, don't ask about the 1st). they replaced the egr valve because the first one was carboned up. that seemed to fix my turbo losing boost while under load but not the idle problem. any ideas. thanks.
ecky is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-08-2010, 05:38 PM
Compression Ignition Addict
 
Join Date: Feb 2009
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
is it a jumping idle or a slow up and down
powerstrokemonster is offline  
post #3 of 3 Old 12-09-2010, 06:36 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
jumping. it doesn't do it everytime i stop either. other than that, the truck seems to run great when i am on the go pedal.
ecky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome