Won't start this morning - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-05-2010, 10:16 AM Thread Starter
crazy canuck's Avatar
Join Date: Mar 2007
Location: Abbotsford B.C.
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Won't start this morning

Hey guys I came out this morning and unplugged my truck to start it up.And when I put the key in and went to turn it over the coil sign did not go off right away like normal and stayed on for about 10 seconds.I then turned the truck over and nothing,it basicly just won't start.Could it be dirty fuel filters?I have owned the truck for 5 months and they have not been changed yet!! I also noticed that the glow plugs were making an unusual loud noise while wrming up as well.....Any help would be great Tanks Troy
crazy canuck is offline  
post #2 of 4 Old 12-12-2010, 01:56 PM
Compression Ignition Addict
Join Date: Nov 2010
Location: Louisville, KY
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes the fuel filters probably need to be changed. Just take the cap off and check it though to be sure. The glow plugs can stay on for up to 120 seconds depending on temperature. But yeah I'd definitely look into the fuel filter situation.
firefighter317 is offline  
post #3 of 4 Old 12-13-2010, 11:21 AM
Powerstroke.org Fanatic
Join Date: Oct 2010
Posts: 141
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Feedback Score: 0 reviews
When you say "nothing" I assume that you mean the engine was turning over, but would not fire off? Could be a number of things. Shouldn't take more than 5 seconds of cranking before it fires off. You'll need to check the FICM and if that's not bad, check the HPOP and IPR and IPC.
divotf15 is offline  
post #4 of 4 Old 12-16-2010, 01:33 PM
Compression Ignition Addict
Chango's Avatar
Join Date: Nov 2010
Location: San Diego, CA
Posts: 310
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
check out the no start thread in my signature

Awesome thread on oil / cold start issues for 6.0 ----> http://www.powerstroke.org/forum/gen...ably-like.html
Troubleshooting a no Start Condition ---> http://www.powerstroke.org/forum/6-0...condition.html
Still using Ford Coolant? ----> http://www.powerstroke.org/forum/6-0...nce-temps.html
Chango is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome