Multiple issues with my new 6.0 - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-27-2005, 05:42 PM Thread Starter Rookie
Join Date: Sep 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Multiple issues with my new 6.0

I have a 05 CC F350 dually with the auto trans...I installed a Juice box, 5" exhaust, and AFE air box at 200 miles. This past weekend I was pulling my other truck to a show 300 miles north and 1/4 of a mile from my house I blew the intake tube off of it, making a nice dent in the hood; and I had it down on stock. I put it back on and it made it another 130 miles before it blew again, this time at the intercooler below the air box. I noticed right before it blew that she was pulling really hard and showed 32 psi of boost on my guage. I dropped the trailer and bobtailed 35 miles back to the nearest dealer. They replaced the hose assembly with the updated aluminum one. I went about my business, but noticed that even in cruise it would pulse every so often and the tranny seemed to be slipping. I took it up the road about an hour ago and turned the box all the way up to see what it would do, and its not even half of what it used to do, and that was only 9000 miles ago. I pulled the juice box off of it just now and am pondering taking it to the dealer tomorrow. I am just wondering if anyone else has had this scenerio and what remedied the problem. I would think it different had I just put the upgrades on it, but since they were installed so early, I doubt that is the problem. And to make things worse, this is the first load I hauled. I am kicking myself right now for selling my 7.3
regan is offline  
Sponsored Links
post #2 of 3 Old 09-28-2005, 04:49 AM
Gun Nut

Rodslinger's Avatar
Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 42 Times in 28 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
I've read where a few people have had the problem with the hose coming off too. It was something as I recall with a clamp and the dealers were aware of it and would replace it with a better one. I need to check mine out.
As far as the performance issue I'm not sure. Maybe someone on here running a setup similar could chime in. I think it's probably just a minor issue - although a PITA for you right now and once it's corrected you'll enjoy you're 6.0 like the rest of us.

NOT that there is a problem with the 7.3 you guys!

'05 F250, CC, FX4, 6.0 PSD
SCT Livewire & Chris at TSD tunes
MTW Stage 1 Turbo
DJ's FUEL+ - Fuel Pressure Intensifier
Nitrous Express NXd Stacker
Snow Performance Stage III Water/Meth Kit
ARP Studs
MBRP 4" Turbo Back w/ no Muffler & no Cat
DashBoss on my iPad
ISSPRO Gauges in Triple A-Pillar
High Idle Mod
Iron Horse Front Bumper Replacement
12,000LB MileMarker Winch
2000Watt Power Inverter
Viper 5901 Remote Start/Alarm
Pioneer Avic-D3 Stereo/Nav
Train Horns!
Valentine 1
Velvet ride shackles
RockStars on 33's
Big azz dent from a blown tire.

"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived."
- General George S. Patton, Jr

Please support our troops!

Rodslinger is offline  
post #3 of 3 Old 09-28-2005, 09:50 AM
Vinyl Sticker Guy

Andy's Avatar
Join Date: Jul 2005
Location: CDA, ID
Posts: 640
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 32 Times in 17 Posts
Feedback Score: 0 reviews
No, there has never been a problem with the 7.3L ever, you are correct

Andy is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome