no power, vibration - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-16-2010, 12:45 PM Thread Starter Rookie
Join Date: Mar 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no power, vibration

hi, new to forum , i have a problem with a 03 ford f350 6.0 126,000 miles.the problem is when you get on it hard it don't have the power it use to and it has a wierd vibation,when you put and skidloader behind it the vibration gets worse,it only does it from 2400-3500 rpm it vibrates all the way up the seat,if you let off the gas it goes away. no codes ,runs great all the other times,new heads,headgasket,egr cooler and head bolts. it also has new hanger bearing. any info would be greatly appreciated. thanks ,jason
camaro69 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome