HELP!! i messed something up - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2010, 12:37 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: kermit texas
Posts: 236
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP!! i messed something up

OK i installed the sinister egr delete kit got everything back together tried to fire it up and it sounds like its only firing on one bank idk i have traced wires everything appears to be plugged in properly any ideas guys i have to get this ironed out

thanks james
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-13-2010, 06:02 PM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,181
Thanks: 13
Thanked 56 Times in 44 Posts
Feedback Score: 4 reviews
Re-check your FICM connections. I know you said you did already, but you really need to recheck them.
Reply With Quote Quick reply to this message
  #3  
Old 03-13-2010, 07:55 PM
Banned
 

Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: -1 reviews
agreed one of the 3 ficm connections in not fully seated. make sure you hear 2 clicks on each connector.
Reply With Quote Quick reply to this message
  #4  
Old 03-13-2010, 08:17 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: kermit texas
Posts: 236
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
THANK YOU!!

thanks thats what it was running great now last time there was an egr problem i took it to the ford house they removed intake and cleaned it the broke the plugs on the ficm it doesn't lock in place and they failed to replace the three bolts that mount the turbo didn't know till yesterday when i took it apart won't be taking in back over there any more but any way thanks for all the help i thought i killed it
Reply With Quote Quick reply to this message
  #5  
Old 03-13-2010, 08:20 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: kermit texas
Posts: 236
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
another note after the 4'' straight pipe cat and muffler delete and the egr delete the 6.0 is running better than ever thanks i wouldn't have thought about doing it if it wasn't for this forum great group of people and a wealth of knowledge

love the group
Reply With Quote Quick reply to this message
  #6  
Old 03-14-2010, 03:17 PM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,181
Thanks: 13
Thanked 56 Times in 44 Posts
Feedback Score: 4 reviews
Great to hear it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors