A little help Please - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2010, 02:56 PM
Powerstroke.org Rookie
 

Join Date: May 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A little help Please

03 F350 4x4, 186596 miles. Died on me last week, like it ran out of fuel. Dealer diagnosed and replaced ICP.

Trouble is now the truck won't get out of it's own way, I can get up to 65 - 70 mph but it takes a while, mash the throttle and nothing, let it off and it picks up, but acceleration is not an option, I have had to park it because I could get killed or worse kill someone on the highway's down here.

Fuel filters are new and no idiot light, I unplugged the EGR today but no change, it was cleaned about 2 months ago.

Any ideas ??

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-09-2010, 03:24 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: north of Pretty Prairie KS
Posts: 283
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bumping this up for you
Reply With Quote Quick reply to this message
  #3  
Old 03-09-2010, 05:24 PM
Powerstroke.org Rookie
 

Join Date: May 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well it's getting late here, and I think I have it figured out.
I am going to pick up a regulator (or rebuild kit) Saturday.
Reply With Quote Quick reply to this message
  #4  
Old 03-14-2010, 03:35 PM
Powerstroke.org Rookie
 

Join Date: May 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Went through the regulator yesterday, checked FICM voltage (good) pulled and cleaned EGR valve.
Disconnected batteries overnight, fired her up this morning, ran pretty good cold, but the warmer the motor got the slower it got. No improvements at all.

Anything over a quarter throttle and all I get is black smoke and no increase in acceleration, let the the throttle come back to a quarter and it will clean up and pull, albeit slowly.
Reply With Quote Quick reply to this message
  #5  
Old 03-14-2010, 03:52 PM
Member
 

Join Date: Jan 2010
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check your vgt solenoid sounds like you have no turbo may not be plugged in
Reply With Quote Quick reply to this message
  #6  
Old 03-21-2010, 12:22 PM
Powerstroke.org Rookie
 

Join Date: May 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Spent the best part of the weekend removing and cleaning the turbo, no change in symptoms.

I'm out of cash and ideas, can anyone "Please" point me in the right direction.
Reply With Quote Quick reply to this message
  #7  
Old 03-30-2010, 05:22 PM
Powerstroke.org Rookie
 

Join Date: May 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Before the motor gets up to operating temp I have all the power I want, as soon as she is warm, I lose it.
Still no codes.

Anyone ?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors