03 6.0 Problems! Need Help! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-05-2010, 04:48 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 6.0 Problems! Need Help!

So I am realitivly new to diesels, I have had mine for 4 months and it has been in the shop twice now. It has the ARP studs and EGR delete done about 5k miles ago. Last time the fly wheel broke, now this time I dont even know where to begin diagnosing.

We were riding down the road tonight and all of a sudden it started running a little rough in lower rpms, then we came to a stop light about 2 miles after it started and it idled a little rough and sounded wired then died.

It wont restart at all so I had it towed in.

What should I check to start diagnosing it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-05-2010, 08:36 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Location: Springfield, VA
Posts: 380
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via ICQ to VeeDubTDI Send a message via AIM to VeeDubTDI Send a message via MSN to VeeDubTDI Send a message via Yahoo to VeeDubTDI
Gotta get a scanner and see what's up. The trouble codes will point you in the right direction, or at least give you somewhere to start. Without knowing what the computer knows, diagnosis is usually hopeless.
Reply With Quote Quick reply to this message
  #3  
Old 03-06-2010, 06:46 AM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Went out and messed with it some this morning, didnt really do anything but check all the connections. Everything looked good, I hoped in it and turned it over, it turned over a few times then came to a rough start. It smoothed out after a few secs and ran normal for about 5 mins. Then started to run rough again at idle, just more vibration and a little louder than normal.

Any idea what this could be, it almost seems like bad fuel but I havnt gotten any fuel light or any check engine lights or anything.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors