High Oil temps after EGR Delete and Oil Cooler - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-28-2010, 07:29 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Soux City, IA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
High Oil temps after EGR Delete and Oil Cooler

Hi, first time poster but I've been lurking for years. I have a problem with high oil temps around 260. Coolant is running around 195. I've just replaced the oil cooler and the egr cooler with a delete kit. I'm stumped and could use a little help. Thanks in advance.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-28-2010, 08:40 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Erie PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you flush the system really good before you changed the oil cooler?
Reply With Quote Quick reply to this message
  #3  
Old 02-28-2010, 09:32 AM
Premium Member
 

Join Date: Dec 2009
Location: Vancouver
Posts: 3,199
Thanks: 1
Thanked 24 Times in 23 Posts
Feedback Score: 0 reviews
Interested to hear what some think.
Reply With Quote Quick reply to this message
  #4  
Old 02-28-2010, 03:39 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Soux City, IA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Drained Flushed and Refilled by the dealer that did the work. I was on the road when it happened so I can't go back there to have it looked at again.
Reply With Quote Quick reply to this message
  #5  
Old 02-28-2010, 06:33 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Jacksonville,Fl
Posts: 3,353
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 5 reviews
Send a message via AIM to Abrannan19
is the clutch fan coming on?
Reply With Quote Quick reply to this message
  #6  
Old 03-01-2010, 03:53 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Soux City, IA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes it is. The engine coolant temps are fine. Just high oil temps.
Reply With Quote Quick reply to this message
  #7  
Old 03-01-2010, 04:03 AM
Member
 

Join Date: Nov 2009
Location: GA
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
abrannan19 how well do you know FCDP? I am just north of them, and had some questions, like do they do the work at their shop? It looks like they do, but there is a rumor that I keep hearing that they only ship out parts? Which makes no sense to me, but do they do the work there?
Reply With Quote Quick reply to this message
  #8  
Old 03-01-2010, 04:36 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Jacksonville,Fl
Posts: 3,353
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 5 reviews
Send a message via AIM to Abrannan19
Quote:
Originally Posted by crunchtime_2009 View Post
abrannan19 how well do you know FCDP? I am just north of them, and had some questions, like do they do the work at their shop? It looks like they do, but there is a rumor that I keep hearing that they only ship out parts? Which makes no sense to me, but do they do the work there?
HAHA, I am FCDP. We do work at our shop, its not parts only, we install everything we sell, If you have any other questions, shoot me an email abrannan19@aol.com
Reply With Quote Quick reply to this message
  #9  
Old 03-01-2010, 11:02 AM
Member
 

Join Date: Nov 2009
Location: GA
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
awesome, I called yall today, I am waiting on my exhaust and programmer to get here today, trying to get my egr delete done this week. You think its a possibility?
Reply With Quote Quick reply to this message
  #10  
Old 03-24-2010, 08:06 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did anyone figure out what was causing the oil temp to be so high ? Im having the same problem the egr and oil cooler are both working and original no problems there.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors