03 6.0 Hard start with zero power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-27-2010, 11:53 AM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 6.0 Hard start with zero power

I have an '03 with 230k mi. The problem occured going down the road at hwy speed, lost total power but would idle fine. Changed fuel filters just in case checked fuel pressure(52 psi at idle) and fuel pressure regulator all fine. Checked voltage on FICM and it checked out. No codes were thrown until 4 days later saying ICP sensor low 2285. Changed the ICP 30K mi ago and visually checked that and no oil blowing out the back of the sensor. Changed the IPR valve and still nothing. Pulled the left side valve cover to see if high pressure oil was leaking from any where obvious. Finally my question is that when spinning the engine over saw oil coming from the top of an injector where the high pressure oil rail plugs in. Is this the culprit? I if so should I replace the injector(s) or replace the o-rings. Ford does not sell an o-ring kit that contains them but I have found aftermarket kits that do. Any advice would be appreciated. Thanks.
moore6oh is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome