EGR replacement - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-26-2010, 12:21 PM Thread Starter
Member
 
fishincowboy83's Avatar
 
Join Date: Jun 2009
Location: Florence, CO.
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
EGR replacement

Ok, I am on my second EGR in three months, I have new injectors as of july last year, and ford has scanned this thing numerous times with no answers. It truly feels like an EGR, no smoke, just jerking on acceleration, especially when cold, once it has warmed up it smooths out. any suggestions would be great. love the truck just not right now.

03 F-350, DRW 4X4, 6.0 6 Spd 70,000 miles. Removed Cat and AFE air box and filter.
fishincowboy83 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-26-2010, 03:27 PM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: Springfield, VA
Posts: 380
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If you have a 2003, just unplug the wiring harness on the EGR. As long as the valve isn't stuck open, that will disable it and won't throw a check engine light. Try that and see if it helps.


1991 Volkswagen Jetta 1.6TD ECOdiesel -- 423,000 miles
2003 Ford F-350 6.0 -- 131,000 miles
1987 Mercedes-Benz 300SDL -- 307,500 miles

2000 Volkswagen New Beetle TDI (RIP)
1987 Mercedes-Benz 190D 2.5 Turbo (sold)


Helpful Links:
6.0 no-start | 6.0 turbo reconditioning | Test your coolant!

VeeDubTDI is offline  
post #3 of 3 Old 02-27-2010, 10:41 AM Thread Starter
Member
 
fishincowboy83's Avatar
 
Join Date: Jun 2009
Location: Florence, CO.
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok, I unplugged the EGR this morning on the way to work and nothing changed. still rough running and studdering through mid power range, put it to the floor and she picks up and takes off. Possibly the FICM, a programming issue, i know the 03 and 04 models were sometimes in need of a flash and reprogram. anyone have any other ideas or possibly confirm my FICM suspissions, and how hard is it to swap one out?
fishincowboy83 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome