04 6.0 problems - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 02-25-2010, 04:52 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
04 6.0 problems

hey guys im hoping some of you can help me out because im completely stumped on whats wrong with my truck. i bought the truck about a week before christmes and right from the beginning it would have problems starting in the morning if i didnt plug it in. but the truck started and ran fine once i plugged it in for an hour or so. about 2 weeks ago i used the truck for a snowmobile trip to new brunswick leaving from ontario. i towed a trailer with 2 sleds in it the whole way there without a problem. while i was there i didnt plug it in the one night and it took and entire day of sitting in a heated shop plugged in to get the truck to start. anyways i left new brunswick that day made it to quebec city and as i was cruising at 100 km/h the truck started to kind of backfire and lose alot of power and i also noticed every time it did it alot of black smoke would come out of the tailpipe i continued to drive but it got worse and worse and about an hour after it started i could only get the truck to do about 20 km/h just enough to baby it off the highway to a rest stop. i had the ficm sent in to get repaired but the tech told me there is nothing wrong with it. i am a mechanic myself but im new to diesel motors and id like to fix the problem myself and not have to take it to a shop to get ripped off. if you guys could give me some advice it would be greatly appreicited sorry for the long story.
04_F250 is offline  
post #2 of 13 Old 02-25-2010, 05:15 AM
Unapologetically American


 
2006PSDSD's Avatar
 
Join Date: Oct 2006
Location: Littleton, Colorado
Posts: 20,018
Thanks: 4
Thanked 29 Times in 28 Posts
Mentioned: 1 Post(s)
Quoted: 20 Post(s)
Feedback Score: 4 reviews
No CEL's? I would say maybe a clogged EGR valve, or a glow plug problem . Heres a free anyway

How many miles are on it? Have you replaced the fuel filters since you bought it? Those can cause some issues, but I'm not sure if they will cause your issues. But the filters should be changed out IMHO


2006 F350 SOLD
* KMC XD Monsters wrapped in Hankook ATM's
* 08 style mirrors
* 4" TB exhaust
* SCT X2 with Gearhead, PHP and ID tunes
* Edge Insight CTS
*Full Bulletproof Diesel kit with remote oil cooler
* Blue FPR spring
* 6.4 Banjos
* Repaired FICM by BPD
* Dfuser coolant filter
* Stage1 MTW turbo



New truck has a Cummins and a handshaker
2006PSDSD is offline  
post #3 of 13 Old 02-25-2010, 05:21 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
the check engine light is not on but just before the trip i plugged in a snap-on scanner and 9 codes came up 1 for each injector and 1 for the ficm. it has 122000 kms on it and i replaced the fuel filters just before the trip. the thing that really doesnt make sense is the truck will sit and idle perfectly fine but as soon as you rev it up to anything over 1000 rpm it backfires/chugs almost like a govenor
04_F250 is offline  
post #4 of 13 Old 02-25-2010, 05:44 AM
Unapologetically American


 
2006PSDSD's Avatar
 
Join Date: Oct 2006
Location: Littleton, Colorado
Posts: 20,018
Thanks: 4
Thanked 29 Times in 28 Posts
Mentioned: 1 Post(s)
Quoted: 20 Post(s)
Feedback Score: 4 reviews
That one is over my head, sorry. Someone will be along to help you out shortly


2006 F350 SOLD
* KMC XD Monsters wrapped in Hankook ATM's
* 08 style mirrors
* 4" TB exhaust
* SCT X2 with Gearhead, PHP and ID tunes
* Edge Insight CTS
*Full Bulletproof Diesel kit with remote oil cooler
* Blue FPR spring
* 6.4 Banjos
* Repaired FICM by BPD
* Dfuser coolant filter
* Stage1 MTW turbo



New truck has a Cummins and a handshaker
2006PSDSD is offline  
post #5 of 13 Old 02-25-2010, 11:23 AM
Banned
 
Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: -1 reviews
if you had a P0611 ficm performance code and all 8 injector low codes, then its time to repair or replace your ficm, because it is done.
fordmasterdieseltech is offline  
post #6 of 13 Old 02-25-2010, 02:18 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by fordmasterdieseltech View Post
if you had a P0611 ficm performance code and all 8 injector low codes, then its time to repair or replace your ficm, because it is done.
what is the easiest way to test the unit in the truck? ive read a couple articles and tried but i cant get a reading
04_F250 is offline  
post #7 of 13 Old 02-25-2010, 03:16 PM
Compression Ignition Addict
 
JAVA JOE's Avatar
 
Join Date: Mar 2008
Location: Riverside,So-Cal
Posts: 299
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I would absolutely first pull and clean your egr valve. Mine was bad and did the same thing. Smoke and no power all of a sudden. Replaced it and all was good. Should of just cleaned it like I did the second time

2004 LARIAT F250 4X4 CC LONG BED
8" LIFT W/ 37'S ON WELD EVO'S AND REAR AIRBAGS
AIRAID INTAKE, 4" STRAIGHT PIPED W 5" TIP
MAG-HYTEK TRANS AND DIFF. PANS
PROCOMP PILLAR GAUGES
SCT X3 RUNNING I.D EXTREME RACE
2000 WATT INFINITY AMPS AND SYSTEM

TT MEMBER

JAVA JOE is offline  
post #8 of 13 Old 02-25-2010, 03:46 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i cleaned the egr, replaced glow plugs, glow plug module, and icp today and i still cant get the truck to start. i did test the ficm and it only read 19 volts while cranking by the sounds of it from other posts that means its no good. so i pulled it apart and looked inside and where it shows it needs to be soldered all the connections look good does it still need to be soldered? any help would be greatly appreiceted
04_F250 is offline  
post #9 of 13 Old 02-25-2010, 05:44 PM
Unapologetically American


 
2006PSDSD's Avatar
 
Join Date: Oct 2006
Location: Littleton, Colorado
Posts: 20,018
Thanks: 4
Thanked 29 Times in 28 Posts
Mentioned: 1 Post(s)
Quoted: 20 Post(s)
Feedback Score: 4 reviews
Yeah, I think you're FICM is toast! They are supposed to be pushing like 40 something volts. Someone was selling a few here today, you might try and find that guys post and see if he still has them


2006 F350 SOLD
* KMC XD Monsters wrapped in Hankook ATM's
* 08 style mirrors
* 4" TB exhaust
* SCT X2 with Gearhead, PHP and ID tunes
* Edge Insight CTS
*Full Bulletproof Diesel kit with remote oil cooler
* Blue FPR spring
* 6.4 Banjos
* Repaired FICM by BPD
* Dfuser coolant filter
* Stage1 MTW turbo



New truck has a Cummins and a handshaker
2006PSDSD is offline  
post #10 of 13 Old 02-26-2010, 01:13 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
new ficm fixed all my problems. thanks for the advice guys. can anyone tell me where to have a custom tune put into the ficm?
04_F250 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome