04 ICP - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2010, 02:17 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Erie PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04 ICP

Hi there everyone I think i have been reading this board for a week straight. I have a couple of questions so please bear with me. first off my truck 04 10600 miles w/03 model year engine egr delete 4" turbo back s&b cold air Edge mostly just to keep an eye on things I tow 18000 pounds 3 or 4 times a year. OK my trouble. just did oil cooler hpop icp irp and oil tubes to the valve covers. Now there telling me I need injectors and the icp is bad again so my question is if the icp is not functioning right can you still diagnose injectors and my icp sensor and harness has been replaced once before and wires are all the same color so dont no if they did it correctly. any help would be greatly appreciated. thanks in advance. the new Icp is 1 week old.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-21-2010, 04:35 PM
Powerstroke Techie

 

Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
First off. I would double check that the correct wires are spliced to the correct locations before going any deeper.
Reply With Quote Quick reply to this message
  #3  
Old 02-21-2010, 05:15 PM
Banned
 

Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: -1 reviews
definetly hard to believe the icp went out already after 1 week. check wire splice location a fitment.
Reply With Quote Quick reply to this message
  #4  
Old 02-22-2010, 12:55 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Erie PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oops its 106000 miles the icp and connector will be here tomorrow. at least the ford garage is going to give me the new part to bad the garage that did the repair wont replace it. wont be going back to them no time soon. thanks for all the help so far so is it possible to diagnose the injectors with a bad icp
Reply With Quote Quick reply to this message
  #5  
Old 02-22-2010, 01:58 PM
Powerstroke Techie

 

Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by simmergencon View Post
oops its 106000 miles the icp and connector will be here tomorrow. at least the ford garage is going to give me the new part to bad the garage that did the repair wont replace it. wont be going back to them no time soon. thanks for all the help so far so is it possible to diagnose the injectors with a bad icp
If the injector control pressure side of the business isn't resolved, NO. Proper injector diagnosis can only be done, when the FICM, fuel supply pressure and injector control pressure end of things are all functioning properly.
Reply With Quote Quick reply to this message
  #6  
Old 02-24-2010, 12:13 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Erie PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
O.k. got the ICP want to check the wiring to make sure it gets hooked up right does anyone on here no were i can find a schematic so I get the right wires on the right terminals I dont trust the last one the was put on. any help would be appreciated thanks in advance.
Reply With Quote Quick reply to this message
  #7  
Old 02-26-2010, 11:21 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Erie PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
put the ICP in and still no luck so decided to go ahead with the injectors. I will stay stock dont need alot more power. when i pulled my first injctor out I noticed it was coming apart the little screw at the top had back out of three of the eight so hopefully this will solve the problem still waiting on the injectors they will be in tues. I will let you no but I am confident this was the problem. thanks for all your help.
Reply With Quote Quick reply to this message
  #8  
Old 02-26-2010, 01:20 PM
Powerstroke Techie

 

Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by simmergencon View Post
put the ICP in and still no luck so decided to go ahead with the injectors. I will stay stock dont need alot more power. when i pulled my first injctor out I noticed it was coming apart the little screw at the top had back out of three of the eight so hopefully this will solve the problem still waiting on the injectors they will be in tues. I will let you no but I am confident this was the problem. thanks for all your help.
You better have a real good look at all your injectors then. If any of those nuts do back out and fall into the sump, they WILL pass through your oil pickup and ruin your low pressure oil pump, and pass through the rest of the engine.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:26 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors