oil sending unit issue - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-19-2010, 07:35 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2006
Location: Nevada
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
oil sending unit issue

My oil pressure gauge on the dash does not move. The truck has the correct oil pressure . We replaced the oil pressure sending unit and it read correctly

1 minute later the gauge again drops and now does not move



motor is a 6.0
DONZI is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-20-2010, 08:56 AM
Banned
 
Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: -1 reviews
did you use a cheapy aftermarket sending unit? if so make sure it is the correct one, and i would recommend a ford oem replacement sending unit for reliablity.
fordmasterdieseltech is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome