hey stump! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2007, 07:17 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: west jordan,utah
Posts: 331
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hey stump!

ok i tried to clean the egr yesterday you were saying to use your imagination to get it out,well i tried that i also tried my strength my anger the twist twist and pull pull and the twist and then pull guess i'll have to use the force or something holy crap that suckers in there lol.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-07-2007, 07:18 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by rottys View Post
ok i tried to clean the egr yesterday you were saying to use your imagination to get it out,well i tried that i also tried my strength my anger the twist twist and pull pull and the twist and then pull guess i'll have to use the force or something holy crap that suckers in there lol.

I hear a cutting torch and jack hammer are needed in cases like this.
Reply With Quote Quick reply to this message
  #3  
Old 04-07-2007, 07:19 PM
SMOKE ROLLER

 

Join Date: Dec 2006
Location: North Augusta, South Carolina
Posts: 1,994
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just unpluged mine... No problems yet except for better throttle response and increased MPG...
Reply With Quote Quick reply to this message
  #4  
Old 04-07-2007, 07:27 PM
im fat and ugly


 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,684
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
try a small pulley puller
Reply With Quote Quick reply to this message
  #5  
Old 04-07-2007, 07:32 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: west jordan,utah
Posts: 331
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ya just dont want any warranty isues .the jack hammers a good idea though!
Reply With Quote Quick reply to this message
  #6  
Old 04-07-2007, 07:44 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: Silver Lake Or.
Posts: 786
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How often would you pull the egr out and clean it? Just curious
Reply With Quote Quick reply to this message
  #7  
Old 04-07-2007, 08:03 PM
im fat and ugly


 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,684
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
well as the old sayin goes if it aint broke dont fix it, but if milage drops when the filters are clean or it starts runnin ruff give it a good cleaning
Reply With Quote Quick reply to this message
  #8  
Old 04-07-2007, 09:43 PM
RET RET is offline
Compression Ignition Addict
 

Join Date: May 2006
Location: Tampa Florida
Posts: 265
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Hayman View Post
How often would you pull the egr out and clean it? Just curious
Mine has been unpluged for the last 2000 miles.
I pulled it to clean it at 12,000 and it was pretty dirty.
Reply With Quote Quick reply to this message
  #9  
Old 04-07-2007, 11:05 PM
Emergency Services
 

Join Date: Oct 2006
Location: tampa, florida
Posts: 1,071
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by RET View Post
Mine has been unpluged for the last 2000 miles.
I pulled it to clean it at 12,000 and it was pretty dirty.
so is it a good idea to do??? what gains do u notice??........unplugging it that is
Reply With Quote Quick reply to this message
  #10  
Old 04-08-2007, 04:53 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,819
Thanks: 7
Thanked 33 Times in 24 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
I unplugged mine a long time ago and didn't notice anything so I plugged it back in after a few days. Maybe I need to check it out again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:28 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors