High EGT temp - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2009, 07:24 AM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
High EGT temp

Hello All, new to the forums!
last week i drove home my new used 250 and the egt's went to 1900. truck has an edge tuner on it that has not been updated. This happened about 4hrs into a 6 hour drive home and only lasted about a half hour and EGTs returned to normal. It actually seemed like the tuner decided to throw an extra 1000 degrees of indication. Instead of varying between say 200 to 850 or so, it was indicating 1200 to 2000 degrees. The motor never skipped a beat when this happened, no codes or anything. any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-21-2009, 07:35 AM
Tennessee Powerstrokes

 

Join Date: Mar 2009
Location: Lebanon TN
Posts: 2,830
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Interesting. I wonder if it was just a glitch. Nothing against Edge products, but they are not good for your tranny. Oh and Welcome to the Addiction um' I mean Org!
Reply With Quote Quick reply to this message
  #3  
Old 12-21-2009, 07:43 AM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: Ogden, Utah
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I ran an Edge Juice on my truck for a while. On a longer pull I noticed that my boost was doing some odd things on the Attitude monitor. It said my boost was 44 lbs climbing a grade with my TT... but my mechanical gauges showed 24. It is like the Edge chip glitched out and changed 0 to 20 for a while, it lasted for about 20 minutes and then returned to normal.

My bet would be that the edge tuner on your truck was just glitching out like it did on my truck.
Reply With Quote Quick reply to this message
  #4  
Old 12-21-2009, 07:56 AM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yea i am definitely thinking a glitch. The edge came on the truck and will be removed soon and a custom tune will go in and then add some guages to monitor with. got 17mpg runnin 75-80, going to back down to 70 w/cruise on thursday and see what happens.
F-250 lovin it so far, glad to be here
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors