HELP! 6.0L loosing all speed on hills please help - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-06-2009, 05:57 PM Thread Starter
Member
 
Join Date: Sep 2009
Location: red deer, AB
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
delete.......

Last edited by Armour; 12-08-2009 at 12:43 AM.
Armour is offline  
post #2 of 4 Old 12-06-2009, 08:17 PM Thread Starter
Member
 
Join Date: Sep 2009
Location: red deer, AB
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
its also -18 degrees farenhite if that helps, and with this tank i ran power service diesel supplement. any ideas|????????
Armour is offline  
post #3 of 4 Old 12-07-2009, 07:01 PM Thread Starter
Member
 
Join Date: Sep 2009
Location: red deer, AB
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Drove the truck home from work this morning started it up seem ed to idle fine then went to get on the highway and couldnt go over 50km/h when i let of the pedal the and went in neutral the truck sounded like it was chugging really slow about to die, i kept driving into the next town going 50 km/h then i pulled over revved the truck up for a bit then accelerated away fine till 80 km/h and same problem then the truck finally died. i cranked and cranked till it finally started then went about a km more and died. cranked but would not start then boosted it and crawled to town and parked it in a shop for the day ANY IDEAS??????? bad lift pump??? bad filter? gelled fuel. i am working and am away from the truck just need some ideaas of what to look for when i get back to the truck tommorow night. also have been having problems with my battery dieing ( i know i could use new batt's) my truck will stay at low voltage after a boost unless i keep my truck hooked up to another truck for 5 minutes to get power to my truck, my radio wont even turn on gauges wont work and my lights go dim could i also have an alternator porblem and could these problems all be related? when i started my truck to drive it and it was crapping out it was -33 degrees celcius which i beleive is - 27 degrees farenhite if this helps. thanks alot any help is greatly appreciated.
Armour is offline  
post #4 of 4 Old 12-10-2009, 02:15 PM
Serving Our Country!
 
Join Date: Sep 2007
Location: Poulsbo, WA
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like a fouled up fuel filter, or your fuel is gelling. PS helps with gelling, but it can't reverse the effects if you had bad fuel to start with.
Good luck,

Ardi Villiard
'08 450 4x4 6 sp man, loaded.....POS
LEMON LAWED 10/8/08

05 F350 FX4 Lariat, CC, LB, auto, loaded
Volant Ram Air intake
4" turbo back, no kitty
Over 100K
ardi villiard is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome